summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD71
1 files changed, 38 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 403a67a62335..89a96a85c20b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: X0rg
+# Maintainer: UnicornDarkness
# Contributor: Tom Kwok <contact@tomkwok.com>
# Contributor: Jorge Barroso <jorge.barroso.11 at gmail dot com>
# Contributor: Roman Kyrylych <Roman.Kyrylych@gmail.com>
@@ -7,50 +7,55 @@
# Contributor: Joshua Stiefer <facedelajunk@gmail.com>
pkgname=exaile
-pkgver=3.4.5
+pkgver=4.1.3
pkgrel=1
pkgdesc="A full-featured Amarok-style media player for GTK+"
arch=('any')
-url="http://www.exaile.org"
+url="https://www.exaile.org/"
license=('GPL2')
-depends=('python2'
- 'gstreamer0.10-python'
- 'gstreamer0.10-good-plugins'
- 'gstreamer0.10-base-plugins'
- 'mutagen'
- 'python2-dbus'
- 'pygtk>=2.10'
- 'librsvg'
- 'desktop-file-utils')
-makedepends=('make' 'help2man')
-optdepends=('pycddb: CD metadata retrieval'
- 'python2-bsddb: music collection support'
- 'gstreamer0.10-bad-plugins: support for more formats'
- 'gstreamer0.10-ugly-plugins: support for more formats'
- 'gstreamer0.10-ffmpeg: support for more formats'
- 'python2-beautifulsoup3: lyricwiki plugin'
- 'python2-notify: notifyosd plugin'
- 'notify-osd: notifyosd plugin'
- 'webkitgtk2: contextinfo plugin'
- 'pywebkitgtk: contextinfo plugin'
- 'python2-pillow: Python Imaging Library (PIL) fork. Python2 version'
- 'streamripper: streamripper plugin'
+depends=('python>=3.8'
+ 'python-bsddb'
+ 'gtk3>=3.24.0'
+ 'gst-python>=1.16.0'
+ 'gst-plugins-base>=1.16.0'
+ 'gst-plugins-good>=1.16.0'
+ 'python-mutagen>=1.44.0'
+ 'python-dbus'
+ 'python-cairo'
+ 'python-gobject>=3.24.0')
+makedepends=('pygobject-devel>=3.24.0' 'help2man')
+checkdepends=('python-pytest')
+optdepends=('udisks2: device detection'
+ 'python-discid: CD info'
+ 'python-musicbrainzngs: CD info / Musicbrainz covers'
+ 'spydaap: DAAP server'
+ 'python-zeroconf: DAAP plugins (daapserver and daapclient)'
+ 'python-pylast: Last.FM integration'
+ 'python-lxml: lyrics from lyricsmania.com (lyricsmania)'
+ 'python-feedparser: podcast plugin'
+ 'webkit2gtk: Wikipedia info'
+ 'libkeybinder3: Xlib-based hotkeys'
+ 'librsvg: scalable icons'
+ 'libnotify: native notifications'
+ 'streamripper: recording streams'
'moodbar: moodbar plugin'
- 'python2-mmkeys: XKeys plugin')
-source=("https://github.com/exaile-dev/exaile/archive/$pkgver.tar.gz")
-install=$pkgname.install
-sha512sums=('9337b86ed2f6a13071615bd46a7a05a6564011a4e1fef4cb42925336864c07854cfe497d8defe65c4e287fd9546de6a51543180c5ce6a84525506e57209914be')
+ 'gst-plugins-bad: BPM Counter plugin'
+ 'python-beautifulsoup4: lyrics from lyrics.wikia.com (lyricwiki)'
+ 'ipython: ipconsole plugin')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/exaile/exaile/archive/$pkgver.tar.gz")
+sha512sums=('16b31331a31f0a2e088f177c8a01ef47603b07fe94cbb19869a4caeaec2da03cacaa07d5b0eb50052645449e07620e2c58f202007108af73e20cf744d70bb556')
build() {
cd "$srcdir/$pkgname-$pkgver"
make PREFIX="/usr"
}
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PYTEST=py.test test
+}
+
package() {
cd "$srcdir/$pkgname-$pkgver"
make PREFIX="/usr" DESTDIR="$pkgdir" install
-
- # fix for clicking files with spaces in names from nautilus
- sed -i "s#%u#%f#" "$pkgdir/usr/share/applications/exaile.desktop"
- sed -i "s|Exec=$pkgdir/*|Exec=/|" "$pkgdir/usr/share/dbus-1/services/org.exaile.Exaile.service"
}