summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9d1ad9e4af0d..12e96529018c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,18 @@
_pkgname=exaile
pkgname=${_pkgname}-git
epoch=1
-pkgver=4.0.2+205+gcf9b3e59
+pkgver=4.1.3beta3+11+g1994772c
pkgrel=1
pkgdesc="music player for gnome, similar to KDEs amarok"
arch=('any')
url="https://www.exaile.org"
license=('GPL')
-depends=('gtk3' 'python-bsddb' 'python-mutagen' 'python-dbus' 'python-gobject'
+depends=('gtk3' 'python-bsddb' 'python-mutagen' 'dbus-python' 'python-gobject'
'python-cairo' 'udisks2' 'librsvg' 'gst-plugins-good')
makedepends=('git' 'help2man')
optdepends=('python-feedparser: podcasts plugin'
'webkit2gtk: wikipedia plugin'
'python-lxml: LyricsMania plugin'
-# 'cddb-py: look up CD tags' #from DEPS: (TODO: This is currently broken on python3, see #608 and #652)
'libkeybinder3: Multimedia keys plugin'
'python-beautifulsoup4: Lyrics Wiki plugin'
'libnotify: Notify plugin'
@@ -24,15 +23,16 @@ optdepends=('python-feedparser: podcasts plugin'
'gnome-screensaver: Pause on screensaver plugin'
'mate-screensaver: Pause on screensaver plugin'
'cinnamon-screensaver: Pause on screensaver plugin'
+ 'xfce4-screensaver: Pause on screensaver plugin'
'moodbar: Moodbar plugin'
- 'python-musicbrainzngs: Musicbrainz cover search plugin'
+ 'python-musicbrainzngs: Musicbrainz cover search plugin & CD tags plugin'
+ 'python-discid: CD tags plugin'
'ipython: Ipython console plugin'
'python-pylast: Last.fm loved tracks plugin'
'gst-plugins-bad: Additional audio codecs'
'gst-plugins-ugly: Additional audio codecs'
'spydaap-git: DAAP server/client')
-checkdepends=('python-mox3'
- 'python-pytest')
+checkdepends=('python-pytest')
provides=("${_pkgname}=${pkgver%%+*}")
conflicts=("${_pkgname}")
source=("${_pkgname}"::git+https://github.com/exaile/exaile.git)
@@ -40,7 +40,7 @@ sha256sums=('SKIP')
pkgver() {
cd "${_pkgname}"
- git describe --long --tags | sed 's/-beta/.beta/;s/-rc/rc/;s/-/+/g'
+ git describe --long --tags | sed 's/-beta/beta/;s/-alpha/alpha/;s/-rc/rc/;s/-/+/g'
}
build() {