summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 15a899189a6f..e1043acea9d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,12 @@
pkgname=exfat-utils-nofuse
pkgver=1.3.0
-pkgrel=2
+pkgrel=3
pkgdesc='Utilities for the exFAT file system without fuse (to prefer exfat kernel module over fuse)'
arch=('i686' 'x86_64' 'mips64el' 'armv6h' 'armv7h' 'arm' 'aarch64')
url='https://github.com/relan/exfat'
license=('GPL2')
depends=('glibc')
-makedepends=('fuse')
provides=('exfat-utils')
conflicts=('fuse-exfat' 'exfat-utils' )
replaces=('exfat-utils')
@@ -18,13 +17,14 @@ sha512sums=('fa3951e16889db65685e1fb71b0c75fc7014a8025c3442bf6164b94ddd51d282a8a
prepare() {
cd exfat-${pkgver}
- # exclude fuse directory
+ # build without fuse
sed -i 's/fuse label mkfs/label mkfs/' Makefile.am
- autoreconf -fiv
+ sed -i '/fuse/d' configure.ac
}
build() {
cd exfat-${pkgver}
+ autoreconf -fiv
./configure --prefix=/usr --sbindir=/usr/bin
make CCFLAGS="${CFLAGS} ${CPPFLAGS} -std=c99" LINKFLAGS="${LDFLAGS}"
}