summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 4 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 925cd1754fc6..52325164e45f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,14 @@
pkgname=exifcleaner-bin
_pkgname=ExifCleaner
pkgver=3.6.0
-pkgrel=2
+pkgrel=3
pkgdesc="Desktop app to clean metadata from images, videos, PDFs, and other files."
arch=('x86_64')
url="https://exifcleaner.com"
license=('MIT')
-
-depends=(
- 'nss'
- 'gtk3'
- 'perl'
-)
+depends=('nss' 'gtk3' 'perl')
provides=('exifcleaner')
-
+install=ExifCleaner-bin.install
source=(
"$pkgname-$pkgver.deb::https://github.com/szTheory/exifcleaner/releases/download/v$pkgver/exifcleaner_${pkgver}_amd64.deb"
'LICENSE::https://github.com/szTheory/exifcleaner/raw/master/LICENSE'
@@ -30,10 +25,5 @@ sha512sums=(
package() {
tar xf "$srcdir/data.tar.xz" -C "$pkgdir/"
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
- install -d "$pkgdir/usr/bin/"
- ln -s "/opt/$_pkgname/exifcleaner" "${pkgdir}/usr/bin/exifcleaner"
-
- # SUID chrome-sandbox for electron 5+ as indicated here: https://github.com/electron/electron/issues/17972#issuecomment-487369441
- chmod 4755 "$pkgdir/opt/$_pkgname/chrome-sandbox"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}