summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c059670c5d2e..00f431a11ddd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,10 @@ url="https://exodus.io"
license=('custom:"Copyright © 2016 Exodus"')
depends=('gconf' 'gtk2' 'nss' 'libxss')
source=("https://exodusbin.azureedge.net/releases/exodus_linux_${pkgver}.zip"
+ "http://marceloneil.com/exodus-icons/icons.zip"
"${pkgname}.desktop")
sha256sums=('639dbcda7b3d0af9cbc268d86c490cd2240dfbc985d8a90ff4f09d0f8997df5b'
+ '5f3da3a79fea80477f38e698a2ea1723320f4b3fc90bf7d615dab12af0d34c1a'
'04676d81272a35a91150a7eec4640e69ca50f2e479d29fad8be90160ee74122c')
package() {
@@ -20,8 +22,14 @@ package() {
cp -a * $pkgdir/opt/$pkgname
rm $pkgdir/opt/$pkgname/{LICENSE*,version}
ln -s /opt/$pkgname/Exodus $pkgdir/usr/bin/$pkgname
-
+
+ # Launcher
install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ #Icons
+ for i in 16x16 32x32 128x128 256x256 512x512; do
+ install -Dm644 $srcdir/icons/icon_$i.png \
+ $pkgdir/usr/share/icons/hicolor/$i/apps/exodus.png
+ done
chmod -R ugo+rX $pkgdir/opt
}