summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 20 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d3a65b94a42
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# shellcheck shell=bash disable=SC2034,SC2154
+# Maintainer: Wu Zhenyu <wuzhenyu@ustc.edu>
+# Updated by https://github.com/Freed-Wu/expect-language-server/blob/main/.github/workflows/main.yml
+pkgname=expect-language-server
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="expect's language server"
+arch=(any)
+url=https://github.com/Freed-Wu/expect-language-server
+depends=(python-pygls python-platformdirs)
+optdepends=(python-pypandoc python-markdown-it-py)
+makedepends=(python-installer)
+license=(GPL3)
+_py=py3
+source=("https://files.pythonhosted.org/packages/$_py/${pkgname::1}/${pkgname//-/_}/${pkgname//-/_}-$pkgver-$_py-none-any.whl")
+sha256sums=('SKIP')
+
+package() {
+ python -m installer -d "$pkgdir" ./*.whl
+}