aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1af079ba0b7a..61720c2b3f4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,29 @@
pkgname=exrootanalysis
pkgver=0.0.23
-pkgrel=1
+pkgrel=2
pkgdesc="A package designed to simplify ROOT tree production and analysis."
url="https://cp3.irmp.ucl.ac.be/projects/ExRootAnalysis"
arch=('i686' 'x86_64')
license=('GPL3')
depends=('root')
+makedepends=('cmake')
source=("${pkgname}-r${pkgver##*.}.zip::https://cp3.irmp.ucl.ac.be/projects/ExRootAnalysis/changeset/${pkgver##*.}/trunk?old_path=%2F&format=zip"
- "fix.patch")
+ "CMakeLists.txt")
sha256sums=('b30897ae035b741fa93f47e7cd5adc5f942d77498c143ef17ef4f1377207086e'
- '6147bc6c3018ff8c80f3ba60f75e210921e3f714fb35d83c40f47b0401df821c')
+ '6b222226a869c0350e14dce754ebcddf43aa6403f4304104a6e720932b805385')
prepare() {
- patch -p 1 < fix.patch
+ cp CMakeLists.txt trunk
}
build() {
- cd "trunk"
+ cmake trunk -DCMAKE_INSTALL_PREFIX="${pkgdir}/usr"
make
}
package() {
- mkdir -p "${pkgdir}/usr/include"
- cp -r "${srcdir}/trunk/ExRootAnalysis" "${pkgdir}/usr/include"
- cp -r "${srcdir}/trunk/lib" "${pkgdir}/usr/"
- cp "${srcdir}/trunk/tmp/src/ExRootAnalysisDict_rdict.pcm" "${pkgdir}/usr/lib/libExRootAnalysisDict_rdict.pcm"
+ make install
}
# Local Variables: