summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 13100a524e09..d13b6627c6e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname='extrae'
pkgdesc='Instrumentation framework to generate execution traces of the most used parallel runtimes (from BSC).'
pkgver='4.0.6.20230802'
-pkgrel='1'
+pkgrel='2'
arch=('x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('LGPL2.1')
@@ -35,6 +35,9 @@ prepare() {
build() {
cd "$srcdir/$pkgname-${pkgver%.*}"
+ # For now, ignore new errors from GCC 14 (see https://gcc.gnu.org/gcc-14/porting_to.html)
+ export CFLAGS="$CFLAGS -Wno-error=incompatible-pointer-types -Wno-error=int-conversion -Wno-error=implicit-function-declaration"
+
# NOTE: The following optional features are NOT enabled:
# * Automatic instrumentation (with dyninst)
# * CUDA support