summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c42083f6f60..03889182142c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,22 @@
# Maintainer: Joan Bruguera Micó <joanbrugueram@gmail.com>
pkgname='extrae'
pkgdesc='Instrumentation framework to generate execution traces of the most used parallel runtimes (from BSC).'
-pkgver='3.7.0'
+pkgver='3.7.1'
pkgrel='1'
arch=('i686' 'x86_64')
url='https://www.bsc.es/discover-bsc/organisation/scientific-structure/performance-tools'
license=('LGPL2.1')
depends=(openmpi libunwind papi libxml2 zlib)
-source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-$pkgver-src.tar.bz2")
-sha512sums=(59e886c41f699f58932c22d17511fb1a9540f814689695b03e959896399a9a9d951d0c44adc3b41612b20bb071a0572f27f4cf2d23e11cbcf7f466225b5c353a)
+source=("https://ftp.tools.bsc.es/$pkgname/$pkgname-$pkgver-src.tar.bz2"
+ extrae-issue-27-fix-pie-address-translation.patch)
+sha512sums=(629816657bb80ecc55d0167967e4f5eb5ebcfc1482a595a842d7b82690613dbbeae566baf724d8c5d753fa52d3672e6570252937eae8a8a6f141d11eb08ed886
+ 3b0fae157fcc6e85be3a5565c2ea3abe8bf35e130de96435a93ba7b3f4b6c30df8982823d36c494633a2c16671664112558393faeead05226b96aa521bb14fba)
+
+prepare() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ patch -Np1 -i "$srcdir/extrae-issue-27-fix-pie-address-translation.patch"
+}
build() {
cd "$srcdir/$pkgname-$pkgver"