summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8df1658165c6..5a69b7b307be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,16 +12,14 @@ pkgname=('faiss-cuda-git' 'python-faiss-cuda-git')
arch=('i686' 'x86_64')
url="https://github.com/facebookresearch/faiss"
license=('MIT')
-pkgver=1.6.1.r90.g9873376
+pkgver=1.6.1.r142.gfa85ddf
pkgrel=1
source=(${_pkgname}::git+https://github.com/facebookresearch/faiss.git
- 'compiler.patch'
- 'tests.patch')
+ 'compiler.patch')
sha256sums=('SKIP'
- '3739947d39ebffb2775607f135743cd30489aa12f41c14e3aec42fbe79822fd3'
- '0e90164da283d87b2ad176449b1ba441b7ce0c6343aa4dbb8d268483bf805ccd')
+ '3739947d39ebffb2775607f135743cd30489aa12f41c14e3aec42fbe79822fd3')
depends=('blas' 'lapack' 'cuda' 'openmp')
-makedepends=('git' 'python' 'python-numpy' 'swig' 'python-setuptools' 'gcc9')
+makedepends=('git' 'python' 'python-numpy' 'swig' 'python-setuptools')
optdepends=('intel-mkl')
@@ -34,7 +32,6 @@ pkgver() {
prepare() {
cd "${srcdir}/${_pkgname}"
patch -p1 < ../compiler.patch # see https://github.com/facebookresearch/faiss/issues/1392
- patch -p1 < ../tests.patch # see https://github.com/facebookresearch/faiss/issues/1394
mkdir -p build
cd build
_CMAKE_FLAGS="\