summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b8303f0820cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=('farmhash')
+pkgver='1.1'
+pkgrel=1
+pkgdesc="FarmHash is a family of hash functions"
+url="https://github.com/google/farmhash"
+depends=('gcc-libs')
+makedepends=('git')
+checkdepends=()
+license=('MIT')
+arch=('i686' 'x86_64')
+source=("git+https://github.com/google/farmhash.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ autoreconf -vif
+ ./configure CXXFLAGS="-g -mavx -maes -O3" --prefix=/usr
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ make all
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="$pkgdir" install
+}
+
+check() {
+ cd "${srcdir}/${pkgname}"
+ make check
+}