summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 19 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f966b8d07fbc..7efac8be6de2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,30 @@
-# Maintainer: noirscape <neko at catgirlsin dot space>
-pkgname=fatattr-git
-_pkgname=fatattr
+# Maintainer: noirscape <deepnavy at waifu dot club>
+pkgname=fatattr-git # '-bzr', '-git', '-hg' or '-svn'
pkgver=1
-pkgrel=1
+pkgrel=2
pkgdesc="Small linux application to see or modify MSDOS attributes in a FAT file system"
-arch=('x86_64' 'i686')
+arch=("any")
url="https://github.com/Terseus/fatattr"
license=('GPL')
depends=()
-makedepends=('git' 'scons' 'clang')
-provides=('fatattr')
-conflicts=('fatattr')
-options=()
-source=(git+https://github.com/Terseus/fatattr.git)
+makedepends=('git' 'scons' 'clang') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=("fatattr")
+conflicts=("fatattr")
+source=("$pkgname"::'git+https://github.com/Terseus/fatattr.git#branch=master')
md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-VCS}"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
build() {
- cd "$srcdir"/"$_pkgname"
+ cd "$srcdir/${pkgname%-VCS}"
scons
}
package() {
- cd "$srcdir"/"$_pkgname"
+ cd "$srcdir/${pkgname%-VCS}"
mkdir -p "$pkgdir"/usr/bin
- install -Dm755 "bin/$_pkgname" "$pkgdir"/usr/bin
-}
+ install -Dm755 "bin/fatattr" "$pkgdir"/usr/bin
+} \ No newline at end of file