summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 942269636629..58e9778b6fb1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,18 @@
pkgname=fava
pkgdesc='Web interface for beancount'
-pkgver=1.19
-pkgrel=1
+pkgver=1.26.2
+pkgrel=2
arch=('any')
url='https://github.com/beancount/fava'
-license=('GPL')
+license=('MIT')
source=("https://files.pythonhosted.org/packages/py3/f/fava/fava-${pkgver}-py3-none-any.whl")
noextract=("fava-${pkgver}-py3-none-any.whl")
-sha256sums=('1dc037146a5afb462a26c733290db03cf034431aaa5fa17bf9eb1c740dae5e69')
-depends=('beancount' 'python-click' 'python-markdown2' 'python-flask' 'python-flask-babel' 'python-cheroot' 'python-simplejson')
+sha256sums=('03b36f39d624a8af2a490ff7e917cebcc8dbeff97c64ef8f0addfd04bc7b54fd')
+depends=('beancount' 'python-setuptools' 'python-click' 'python-markdown2' 'python-flask' 'python-flask-babel' 'python-cheroot' 'python-simplejson')
makedepends=('python-pip')
package () {
- PIP_CONFIG_FILE=/dev/null pip install --isolated --root="${pkgdir}" --ignore-installed --no-deps fava-${pkgver}-py3-none-any.whl
- python -O -m compileall "${pkgdir}/usr/lib/python3.9/site-packages/${pkgname}/"
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="${pkgdir}" --ignore-installed --no-deps --no-warn-script-location fava-${pkgver}-py3-none-any.whl
+ python -O -m compileall "${pkgdir}/usr/lib/python3.*/site-packages/${pkgname}/"
}