summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1a0add2a627
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Andreas Schreiner <andreas.schreiner@sonnenmulde.at>
+pkgname=fcdctlpp
+pkgver=0.4.4
+pkgrel=1
+pkgdesc="A simple command line utility to set the frequency and gain of the Funcube Dongle SDR Receiver - Pro Plus version"
+url="http://www.oz9aec.net/index.php/funcube-dongle"
+license=('GPL3')
+source=(https://github.com/csete/fcdctl/archive/v${pkgver}.tar.gz)
+sha512sums=('5ee17c4d5dc6203a311077c293bcfbd3d3d6ae2ae3adad6d3f891e88736508946c07774e3057fe03f19807960f99ccfe3eb9af62bd5821ff8c0a12d6c3f65cab')
+arch=('i686' 'x86_64')
+depends=('libusb')
+makedepends=()
+conflicts=('fcdctl')
+
+build() {
+ cd $srcdir/fcdctl-${pkgver}
+ make clean
+ make fcdpp
+}
+
+package() {
+ cd $srcdir/fcdctl-${pkgver}
+ install -m755 -D "$srcdir/fcdctl-${pkgver}/fcdctl" "$pkgdir/usr/bin/fcdctl"
+ install -m755 -D "$srcdir/fcdctl-${pkgver}/funcube-dongle-proplus.rules" "$pkgdir/etc/udev/rules.d/68-funcube-dongle-proplus.rules"
+}