summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD47
1 files changed, 13 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2148a6acb706..8d0f713639c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,26 +6,24 @@
## Mozc compile option
_bldtype=Release
-_mozcver=2.20.2677.102
-_dicver=20171002
-_revision=2
-_fcitxver=2.18.2612.102.1
+_mozcver=2.23.2815.102
+_dicver=20180301
+_revision=1
_pkgbase=mozc
pkgname=mozc-neologd-ut
-true && pkgname=('fcitx-mozc-neologd-ut' 'mozc-neologd-ut')
+true && pkgname=('mozc-neologd-ut' 'fcitx-mozc-neologd-ut')
pkgver=${_mozcver}.${_dicver}.${_revision}
pkgrel=1
arch=('i686' 'x86_64')
url="https://osdn.net/users/utuhiro/pf/utuhiro/files/"
license=('custom')
-makedepends=('clang' 'ninja' 'pkg-config' 'python2' 'curl' 'gtk2' 'qt4' 'zinnia' 'fcitx' 'qt5-base')
-source=('mozc-neologd-ut-2.20.2677.102.20171002.2.tar.xz::https://osdn.net/frs/chamber_redir.php?m=jaist&f=%2Fusers%2F16%2F16042%2Fmozc-neologd-ut-2.20.2677.102.20171002.2.tar.xz'
- http://download.fcitx-im.org/fcitx-mozc/fcitx-mozc-${_fcitxver}.patch
+makedepends=('clang' 'ninja' 'pkg-config' 'python2' 'curl' 'gtk2' 'qt5-base' 'zinnia' 'fcitx' 'libxcb' 'glib2' 'bzip2' 'unzip')
+
+source=('mozc-neologd-ut-2.23.2815.102.20180301.1.tar.xz::https://osdn.net/frs/chamber_redir.php?m=ymu&f=%2Fusers%2F16%2F16721%2Fmozc-neologd-ut-2.23.2815.102.20180301.1.tar.xz'
http://download.fcitx-im.org/fcitx-mozc/fcitx-mozc-icon.tar.gz)
-sha1sums=('1f713933d3a15c15767b83635e63e0af5e98e533'
- 'afeef31bf3d640f9cc630c2187dbfd4507367d78'
+sha1sums=('SKIP'
'883f4fc489a9ed1c07d2d2ec37ca72509f04ea5d')
prepare() {
@@ -34,31 +32,21 @@ prepare() {
# Adjust to use python2
find . -name \*.py -type f -exec sed -i -e "1s|python.*$|python2|" {} +
find . -regex '.*\.gypi?$' -type f -exec sed -i -e "s|'python'|'python2'|g" {} +
-
- # Apply fcitx patch
- patch -Np2 -i "${srcdir}/fcitx-mozc-${_fcitxver}.patch"
}
build() {
cd mozc-neologd-ut-${pkgver}/src
- # Use Qt4
- _rcc_loc=`pkg-config QtCore --variable=rcc_location`
- _qt4dir=${_rcc_loc%%/bin/rcc}
- _qt4i=`pkg-config --cflags-only-I QtGui`
- CFLAGS+=" $_qt4i"
- CXXFLAGS+=" $_qt4i"
-
- _targets="server/server.gyp:mozc_server gui/gui.gyp:mozc_tool unix/fcitx/fcitx.gyp:fcitx-mozc unix/fcitx/fcitx.gyp:gen_fcitx_mozc_i18n renderer/renderer.gyp:mozc_renderer"
+ _targets="server/server.gyp:mozc_server gui/gui.gyp:mozc_tool renderer/renderer.gyp:mozc_renderer unix/fcitx/fcitx.gyp:fcitx-mozc unix/fcitx/fcitx.gyp:gen_fcitx_mozc_i18n"
- QTDIR=$_qt4dir GYP_DEFINES="document_dir=/usr/share/licenses/${pkgbase}" python2 build_mozc.py gyp
+ GYP_DEFINES="document_dir=/usr/share/licenses/${pkgbase}" python2 build_mozc.py gyp --target_platform=Linux
python2 build_mozc.py build -c $_bldtype $_targets
}
package_mozc-neologd-ut() {
pkgdesc="A Japanese Input Method for Chromium OS, Windows, Mac and Linux (the Open Source Edition of Google Japanese Input)"
arch=('i686' 'x86_64')
- depends=('qt4' 'zinnia')
+ depends=('qt5-base' 'zinnia')
conflicts=('fcitx-mozc' 'mozc' 'fcitx-mozc-ut2' 'mozc-ut2' 'fcitx-mozc-ut' 'mozc-ut')
cd mozc-neologd-ut-${pkgver}/src
install -D -m 755 out_linux/${_bldtype}/mozc_server "${pkgdir}/usr/lib/mozc/mozc_server"
@@ -86,15 +74,6 @@ package_fcitx-mozc-neologd-ut() {
install -D -m 644 unix/fcitx/fcitx-mozc.conf "${pkgdir}/usr/share/fcitx/addon/fcitx-mozc.conf"
install -D -m 644 unix/fcitx/mozc.conf "${pkgdir}/usr/share/fcitx/inputmethod/mozc.conf"
- install -d "${pkgdir}/usr/share/fcitx/mozc/icon"
- install -m 644 "${srcdir}/fcitx-mozc-icons/mozc.png" "${pkgdir}/usr/share/fcitx/mozc/icon/mozc.png"
- install -m 644 "${srcdir}/fcitx-mozc-icons/mozc-alpha_full.png" "${pkgdir}/usr/share/fcitx/mozc/icon/mozc-alpha_full.png"
- install -m 644 "${srcdir}/fcitx-mozc-icons/mozc-alpha_half.png" "${pkgdir}/usr/share/fcitx/mozc/icon/mozc-alpha_half.png"
- install -m 644 "${srcdir}/fcitx-mozc-icons/mozc-direct.png" "${pkgdir}/usr/share/fcitx/mozc/icon/mozc-direct.png"
- install -m 644 "${srcdir}/fcitx-mozc-icons/mozc-hiragana.png" "${pkgdir}/usr/share/fcitx/mozc/icon/mozc-hiragana.png"
- install -m 644 "${srcdir}/fcitx-mozc-icons/mozc-katakana_full.png" "${pkgdir}/usr/share/fcitx/mozc/icon/mozc-katakana_full.png"
- install -m 644 "${srcdir}/fcitx-mozc-icons/mozc-katakana_half.png" "${pkgdir}/usr/share/fcitx/mozc/icon/mozc-katakana_half.png"
- install -m 644 "${srcdir}/fcitx-mozc-icons/mozc-dictionary.png" "${pkgdir}/usr/share/fcitx/mozc/icon/mozc-dictionary.png"
- install -m 644 "${srcdir}/fcitx-mozc-icons/mozc-properties.png" "${pkgdir}/usr/share/fcitx/mozc/icon/mozc-properties.png"
- install -m 644 "${srcdir}/fcitx-mozc-icons/mozc-tool.png" "${pkgdir}/usr/share/fcitx/mozc/icon/mozc-tool.png"
+ install -d ${pkgdir}/usr/share/fcitx/mozc/icon
+ install -m 644 $srcdir/fcitx-mozc-icons/*.png ${pkgdir}/usr/share/fcitx/mozc/icon/
}