summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c42909a4115d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: OriginCode <origincoder@yahoo.com>
+
+pkgname=fcitx5-anthy-git
+pkgver=r139.b9ac495
+pkgrel=1
+pkgdesc="Anthy input method for fcitx5"
+arch=('x86_64')
+url="https://github.com/fcitx/fcitx5-anthy"
+license=('GPL')
+depends=('fcitx5-git' 'anthy' 'hicolor-icon-theme')
+makedepends=('cmake' 'git')
+conflicts=('fcitx-anthy')
+provides=('fcitx5-anthy')
+source=('git+https://github.com/fcitx/fcitx5-anthy.git')
+sha512sums=('SKIP')
+
+pkgver() {
+ cd fcitx5-anthy
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd fcitx5-anthy
+
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_LIBDIR=/usr/lib .
+ make
+}
+
+package() {
+ cd fcitx5-anthy
+ make DESTDIR="$pkgdir" install
+}