summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 05bf4133773c..63a7db151cb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
# Maintainer: Felix Yan <felixonmars@archlinux.org>
pkgname=fcitx5-pinyin-zhwiki
-pkgver=20200501
-pkgrel=2
+pkgver=20200520
+_converterver=0.2.1
+pkgrel=1
pkgdesc="Fcitx 5 Pinyin Dictionary from zh.wikipedia.org"
arch=('any')
url="https://github.com/felixonmars/fcitx5-pinyin-zhwiki"
license=('GFDL' 'CCPL:by-sa')
makedepends=('libime' 'opencc' 'pypinyin')
-source=("https://github.com/felixonmars/fcitx5-pinyin-zhwiki/archive/0.2/$pkgname-0.2.tar.gz"
+source=("https://github.com/felixonmars/fcitx5-pinyin-zhwiki/archive/$_converterver/$pkgname-$_converterver.tar.gz"
https://dumps.wikimedia.org/zhwiki/$pkgver/zhwiki-$pkgver-all-titles-in-ns0.gz)
-md5sums=('48335943da934c1f4be18537b48ea051'
- '4d2ee3cf2637abe67bf1332465f57f45')
+md5sums=('2d01f45a73b7c686fef5c44472a9572b'
+ '7e783c4611c642c64c50a7507fdb8d09')
prepare() {
- cd $pkgname-0.2
+ cd $pkgname-$_converterver
cp ../zhwiki-$pkgver-all-titles-in-ns0.gz ./
}
build() {
- cd $pkgname-0.2
- make FILENAME=zhwiki-$pkgver-all-titles-in-ns0
+ cd $pkgname-$_converterver
+ make VERSION=$pkgver
}
package() {
- cd $pkgname-0.2
- make DESTDIR="$pkgdir" install
+ cd $pkgname-$_converterver
+ make VERSION=$pkgver DESTDIR="$pkgdir" install
}