summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8c00d3fb12a5..4dac03078431 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
pkgname=fdiff-git
-pkgver=v1.0.2.r8.g4961155
-pkgrel=2
+pkgver=2.0.0.r7.g970008d
+pkgrel=1
pkgdesc='An OpenType table diff tool for fonts based on the fontTools TTX format'
arch=(any)
url="https://github.com/source-foundry/${pkgname%-git}"
license=('MIT')
-depends=('python' 'python-aiodns' 'python-aiofiles' 'python-aiohttp' 'python-fonttools>=4.8.1')
-makedepends=('python-setuptools')
+depends=('python' 'python-aiodns' 'python-aiofiles' 'python-aiohttp' 'python-fonttools')
+makedepends=('git' 'python-setuptools')
provides=("${pkgname%-git}")
-conflicts=("${provides[@]}")
+conflicts=("${pkgname%-git}")
source=("$pkgname::git+$url.git")
sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
git describe --long --tags --abbrev=7 HEAD |
- sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {