summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8a97e70434d..49e55e360163 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,30 @@
-# Maintainer: Daniel Martí <mvdan@mvdan.cc>
+# Contributor: Daniel Martí <mvdan@mvdan.cc>
pkgname=fdroidcl
_name="${pkgname}"
pkgver=0.5.0
-pkgrel=2
+pkgrel=3
pkgdesc="F-Droid desktop client"
url="https://github.com/mvdan/${_name}"
license=('BSD')
arch=('i686' 'x86_64')
depends=('android-tools')
makedepends=('git' 'go')
-source=("git+${url}#tag=v${pkgver}")
-sha1sums=('SKIP')
+source=("${url}/archive/refs/tags/v${pkgver}.tar.gz")
+sha1sums=('5a623e52c5531a200a324087ef9e68cfdce21b02')
build() {
- cd "${srcdir}/${_name}"
- GO111MODULE=on go build -trimpath -ldflags='-s -w'
+ cd "${srcdir}/${_name}-${pkgver}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build
}
package() {
- cd "${srcdir}/${_name}"
+ cd "${srcdir}/${_name}-${pkgver}"
install -Dm755 "${_name}" "${pkgdir}/usr/bin/${_name}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm644 contrib/completion/zsh/_fdroidcl "${pkgdir}/usr/share/zsh/vendor-completions/_fdroidcl"