summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 9 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ec7e23c4d2c..c38b0431080a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,33 +2,33 @@
_pkgname=featherpad
pkgname=$_pkgname-git
-pkgver=r110.e54a5c6
+pkgver=1.2.0.2.g352c6aa
pkgrel=1
pkgdesc='Lightweight Qt5 plain text editor for Linux'
arch=('i686' 'x86_64')
-url='https://github.com/tsujan/FeatherPad'
+url='https://github.com/tsujan/featherpad'
license=('GPL3')
-depends=('qt5-svg' 'qt5-x11extras' 'desktop-file-utils' 'gtk-update-icon-cache')
-makedepends=('git' 'qt5-tools')
-optdepends=('qt5-translations: localized keyboard shortcuts')
+depends=('qt6-svg' 'hunspell' 'desktop-file-utils' 'gtk-update-icon-cache')
+makedepends=('git' 'cmake' 'qt6-tools')
+optdepends=('qt6-translations: localized keyboard shortcuts')
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("$_pkgname::git+https://github.com/tsujan/FeatherPad.git")
+source=("git+${url}.git")
sha256sums=("SKIP")
pkgver() {
cd $_pkgname
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --always | sed "s:^V::;s:-:.:g"
}
build() {
rm -Rf build && mkdir build
cd build
- qmake $srcdir/$_pkgname/ CONFIG+=debug
+ cmake $srcdir/$_pkgname/ -DENABLE_QT5=OFF
make
}
package() {
cd build
- make INSTALL_ROOT=$pkgdir install
+ make DESTDIR="${pkgdir}" install
}