summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 5 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 14940474a751..51afe3788775 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,8 @@
-# Contributor: Guillaume DOLLÉ <dolle.guillaume at gmail.com>
-# Contributor: George Eleftheriou <eleftg>
-
pkgname=feelpp
-pkgver=0.107.0
+pkgver=0.108.0
pkgrel=1
pkgdesc="Finite Element Embedded Language and Library in C++"
-arch=('i686' 'x86_64')
+arch=('x86_64')
url="https://github.com/feelpp"
license=('LGPL')
depends=('cln' 'mumps' 'slepc' 'gmsh' 'fftw' 'ann' 'glpk' 'gsl' 'python')
@@ -17,9 +14,6 @@ prepare() {
cd ${pkgname}-${pkgver}
git submodule init
git submodule update -f --init
-
- # https://github.com/feelpp/feelpp/pull/1415
- git cherry-pick cad7be165e2c4e377a4acfcf89abfb5365b43601 8b29331f5b2a4c6f47631b788829d5529eaf2d17
}
build() {
@@ -37,14 +31,15 @@ build() {
-DFEELPP_ENABLE_PYFEELPP_LIBFEELPP=OFF \
-DFEELPP_ENABLE_DOCUMENTATION=OFF \
-DFEELPP_ENABLE_GMSH=ON \
- -DFEELPP_ENABLE_PETSC=OFF \
- -DFEELPP_ENABLE_SLEPC=OFF \
+ -DFEELPP_ENABLE_PETSC=ON \
+ -DFEELPP_ENABLE_SLEPC=ON \
-DFEELPP_ENABLE_ANN=ON \
-DFEELPP_ENABLE_FFTW=ON \
-DFEELPP_ENABLE_GSL=ON \
-DFEELPP_ENABLE_SYSTEM_EIGEN3=ON \
-DCMAKE_C_COMPILER=/usr/bin/clang \
-DCMAKE_CXX_COMPILER=/usr/bin/clang++ \
+ -DBUILD_TESTING=OFF \
..
make
}