summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 710bbef68fca..3b4815a84611 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,13 @@
# Maintainer: Tony Nguyen <v35gtr@hotmail.com>
+# Contributor: Alexander Rødseth <rodseth@gmail.com>
+
pkgname=felix
-pkgver=2019.01.06.r79.gd78b73884
+pkgver=2019.01.06.r82.gb2de456f4
pkgrel=1
pkgdesc='The Felix programming language'
arch=('x86_64')
url='https://github.com/felix-lang/felix'
-license=('Felix is free for any use.')
+license=('Felix is Free For Any Use (FFAU)/Public Domain.')
depends=('python3' 'gcc' 'gmp' 'gsl' 'sdl2' 'sdl2_ttf' 'sdl2_gfx' 'sdl2_image')
makedepends=('ocaml')
source=("${pkgname}::git+https://github.com/felix-lang/felix")
@@ -14,7 +16,7 @@ sha512sums=('SKIP')
prepare() {
cd "$pkgname"
- # SDL2 on Arch is installed at /usr instead of /usr/local
+ # Arch Linux installs SLD2 to /usr instead of /usr/local
sed -i 's|usr/local|usr|g' src/packages/sdl.fdoc
}
@@ -25,7 +27,13 @@ pkgver() {
build() {
cd "$pkgname"
- make
+ make build
+ make doc
+}
+
+check() {
+ cd "$pkgname"
+ make test
}
package() {