summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 26689bb1d136..93c175f17af1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=ffmpeg-amd-full-git
_srcname=ffmpeg
-pkgver=6.2.r112766.g575efc0406
+pkgver=6.2.r112865.g3bca828d39
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (all possible features for AMD; git version)'
arch=('x86_64')
@@ -24,8 +24,8 @@ depends=('alsa-lib' 'aom' 'aribb24' 'avisynthplus' 'bzip2' 'celt' 'codec2'
'sndio' 'speex' 'spirv-tools' 'srt' 'svt-av1' 'svt-hevc' 'svt-vp9' 'tesseract'
'twolame' 'v4l-utils' 'vapoursynth' 'vid.stab' 'vmaf' 'vulkan-icd-loader' 'x264'
'x265' 'xvidcore' 'xz' 'zeromq' 'zimg' 'zlib' 'zvbi'
- 'chromaprint-fftw' 'davs2' 'flite1' 'libklvanc-git' 'librist'
- 'shine' 'uavs3d-git' 'vo-amrwbenc' 'xavs' 'xavs2')
+ 'libaribcaption' 'chromaprint-fftw' 'davs2' 'flite1' 'libklvanc' 'librist'
+ 'opencv2' 'shine' 'uavs3d-git' 'vo-amrwbenc' 'xavs' 'xavs2' 'xevd' 'xeve')
makedepends=('git' 'clang' 'amf-headers' 'nasm' 'opencl-headers'
'vulkan-headers' 'decklink-sdk')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
@@ -34,14 +34,16 @@ provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
conflicts=('ffmpeg')
_svt_hevc_ver='6cca5b932623d3a1953b165ae6b093ca1325ac44'
_svt_vp9_ver='43ef8e5e96932421858762392adbbab57c84aebf'
-source=('git+https://git.ffmpeg.org/ffmpeg.git'
+source=("git+https://git.ffmpeg.org/ffmpeg.git"
+ "005-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"
"010-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/${_svt_hevc_ver}/ffmpeg_plugin/master-0001-lavc-svt_hevc-add-libsvt-hevc-encoder-wrapper.patch"
#"020-ffmpeg-add-svt-hevc-docs-g${_svt_hevc_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-HEVC/${_svt_hevc_ver}/ffmpeg_plugin/0002-doc-Add-libsvt_hevc-encoder-docs.patch"
"030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"::"https://raw.githubusercontent.com/OpenVisualCloud/SVT-VP9/${_svt_vp9_ver}/ffmpeg_plugin/master-0001-Add-ability-for-ffmpeg-to-run-svt-vp9.patch"
- '040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch'
- '060-ffmpeg-fix-segfault-with-avisynthplus.patch'
- 'LICENSE')
+ "040-ffmpeg-add-av_stream_get_first_dts-for-chromium.patch"
+ "060-ffmpeg-fix-segfault-with-avisynthplus.patch"
+ "LICENSE")
sha256sums=('SKIP'
+ '7d7a53ee6826acf44d6729d337f30fa8ebb85011a2793261575b7bad230835cb'
'e8fdc940474f3819b9a8d30cab8164774584c051322acb6194bcb03d56e8175a'
#'a164ebdc4d281352bf7ad1b179aae4aeb33f1191c444bed96cb8ab333c046f81'
'0433016c8523c7ce159523946a76c8fa06a926f33f94b70e8de7c2082d14178c'
@@ -51,6 +53,9 @@ sha256sums=('SKIP'
prepare() {
rm -f ffmpeg/libavcodec/libsvt_{hevc,vp9}.c
+ cp --remove-destination "$(readlink "010-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch")" \
+ "010-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"
+ patch -Np1 -i "005-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/010-ffmpeg-add-svt-hevc-g${_svt_hevc_ver:0:7}.patch"
#patch -d ffmpeg -Np1 -i "${srcdir}/020-ffmpeg-add-svt-hevc-docs-g${_svt_hevc_ver:0:7}.patch"
patch -d ffmpeg -Np1 -i "${srcdir}/030-ffmpeg-add-svt-vp9-g${_svt_vp9_ver:0:7}.patch"
@@ -98,6 +103,7 @@ build() {
--enable-lcms2 \
--enable-libaom \
--enable-libaribb24 \
+ --enable-libaribcaption \
--enable-libass \
--enable-libbluray \
--enable-libbs2b \
@@ -128,7 +134,7 @@ build() {
--enable-libmp3lame \
--enable-libopencore-amrnb \
--enable-libopencore-amrwb \
- --disable-libopencv \
+ --enable-libopencv \
--enable-libopenh264 \
--enable-libopenjpeg \
--enable-libopenmpt \
@@ -166,6 +172,8 @@ build() {
--enable-libwebp \
--enable-libx264 \
--enable-libx265 \
+ --enable-libxevd \
+ --enable-libxeve \
--enable-libxavs \
--enable-libxavs2 \
--enable-libxcb \