summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 20 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0d85e80e7770..266ec4001cee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: Jan Koppe <post@jankoppe.de>
pkgname=ffmpeg-decklink
-pkgver=4.2.2
-pkgrel=4
+pkgver=4.2.3
+pkgrel=1
epoch=1
pkgdesc='Complete solution to record, convert and stream audio and video (decklink enabled)'
arch=('x86_64')
@@ -57,7 +57,9 @@ depends=(
'opus'
'sdl2'
'speex'
+ 'srt'
'v4l-utils'
+ 'vmaf'
'xz'
'zlib'
)
@@ -67,24 +69,31 @@ makedepends=(
# AUR:
'decklink-sdk'
)
-optdepends=('intel-media-sdk: for Intel Quick Sync Video'
- 'ladspa: for LADSPA filters')
+optdepends=('avisynthplus: for reading AviSynth scripts as input'
+ 'intel-media-sdk: for Intel Quick Sync Video'
+ 'ladspa: for LADSPA filters'
+ 'nvidia-utils: Nvidia NVDEC/NVENC support')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavutil.so' 'libpostproc.so' 'libswresample.so' 'libswscale.so'
'ffmpeg')
conflicts=('ffmpeg')
source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"{,.asc}
- 'ffmpeg-full-add-decklink-11.5-support.patch'::'https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/f32f9231dd4f74d9f95eef575b838bdc3e06a234'
+ '010-ffmpeg-fix-vmaf-model-path.patch'
+ '011-ffmpeg-add-decklink-11.5-support.patch'::'https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/f32f9231dd4f74d9f95eef575b838bdc3e06a234'
+ '012-ffmpeg-dont-adjust-mp3-start-time.patch'::'https://git.ffmpeg.org/gitweb/ffmpeg.git/patch/460132c9980f8a1f501a1f69477bca49e1641233'
'LICENSE')
-sha256sums=('cb754255ab0ee2ea5f66f8850e1bd6ad5cac1cd855d0a2f4990fb8c668b0d29c'
+sha256sums=('9df6c90aed1337634c1fb026fb01c154c29c82a64ea71291ff2da9aacb9aad31'
'SKIP'
+ 'b6fcef2f4cbb1daa47d17245702fbd67ab3289b6b16f090ab99b9c2669453a02'
'd23dedb5a275d1d753d30fd544a46d5b609868ad5d384b9c8c2ecc1a02281828'
+ '269555538ec6d410b42ec43d22edd3eff2006208a1d4cbc8a028d9a432b81577'
'04a7176400907fd7db0d69116b99de49e582a6e176b3bfb36a03e50a4cb26a36')
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
prepare() {
- # add decklink-sdk 11.5 support
- patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/ffmpeg-full-add-decklink-11.5-support.patch"
+ patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/010-ffmpeg-fix-vmaf-model-path.patch"
+ patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/011-ffmpeg-add-decklink-11.5-support.patch"
+ patch -d "ffmpeg-${pkgver}" -Np1 -i "${srcdir}/012-ffmpeg-dont-adjust-mp3-start-time.patch"
}
build() {
@@ -97,6 +106,7 @@ build() {
--disable-debug \
--disable-static \
--disable-stripping \
+ --enable-avisynth \
--enable-fontconfig \
--enable-gmp \
--enable-gnutls \
@@ -122,10 +132,12 @@ build() {
--enable-libpulse \
--enable-libsoxr \
--enable-libspeex \
+ --enable-libsrt \
--enable-libssh \
--enable-libtheora \
--enable-libv4l2 \
--enable-libvidstab \
+ --enable-libvmaf \
--enable-libvorbis \
--enable-libvpx \
--enable-libwebp \
@@ -141,7 +153,6 @@ build() {
--enable-version3 \
--enable-nonfree \
--enable-decklink
-
make
make tools/qt-faststart
}