summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83f2e2632bac..8a647d97170f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,14 +25,14 @@
pkgname=ffmpeg-full-nvenc
_pkgbasename=ffmpeg
pkgver=4.1.3
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc="Record, convert, and stream audio and video (all codecs including Nvidia NVENC)"
arch=('i686' 'x86_64')
url="http://ffmpeg.org/"
license=('custom: nonfree and unredistributable')
depends=('alsa-lib' 'aom' 'bzip2' 'celt' 'chromaprint-fftw' 'codec2' 'davs2' 'fontconfig'
- 'ffnvcodec-headers' 'frei0r-plugins' 'fribidi' 'glibc' 'gsm' 'jack' 'kvazaar'
+ 'ffnvcodec-headers' 'frei0r-plugins' 'fribidi' 'glibc' 'gsm' 'jack'
'ladspa' 'lame' 'lensfun' 'libass' 'libavc1394' 'libbluray' 'libbs2b' 'libcaca'
'libcdio-paranoia' 'libdc1394' 'libfdk-aac' 'libgme' 'libiec61883'
'libilbc' 'libmodplug' 'libomxil-bellagio' 'libmysofa' 'libpulse'
@@ -81,6 +81,11 @@ build() {
fi
local _ldflags="-L/opt/cuda/lib64 ${_nvidia_340xx_ldflags}"
local _ldflags="${_ldflags} -Wl,-rpath -Wl,/opt/intel/mediasdk/lib64:/opt/intel/mediasdk/plugins"
+
+ # fix tensorflow include dir
+ ## upstream ffmpeg excects : /usr/include/tensorflow/
+ ## tensorflow package ships: /usr/include/tensorflow/tensorflow/
+ _cflags+=' -I/usr/include/tensorflow'
# strictly specifying nvcc path is needed if package is installing
# cuda for the first time (nvcc path will be in $PATH only after relogin)
@@ -155,7 +160,7 @@ build() {
--enable-libilbc \
--enable-libjack \
--enable-libklvanc \
- --enable-libkvazaar \
+ --disable-libkvazaar \
--enable-liblensfun \
--enable-libmodplug \
--enable-libmp3lame \