summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d38d6403a2fb..d653c80329d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: DrZaius <lou at fakeoutdoorsman.com>
pkgname=ffmpeg-git
-pkgver=6.1.r110336.g0dceda12e7
+pkgver=6.1.r111232.g468615f204
pkgrel=1
pkgdesc='Complete solution to record, convert and stream audio and video (git version)'
arch=('x86_64')
@@ -31,7 +31,6 @@ depends=(
libgl
libiec61883
libjxl.so
- libmfx
libmodplug
libopenmpt.so
libpulse
@@ -49,7 +48,6 @@ depends=(
libvorbisenc.so
libvorbis.so
libvpx.so
- libvulkan.so
libwebp
libx11
libx264.so
@@ -61,6 +59,7 @@ depends=(
libxvidcore.so
libzimg.so
ocl-icd
+ onevpl
opencore-amr
openjpeg2
opus
@@ -70,6 +69,7 @@ depends=(
svt-av1
v4l-utils
vmaf
+ vulkan-icd-loader
xz
zlib
)
@@ -86,9 +86,9 @@ makedepends=(
vulkan-headers
)
optdepends=('avisynthplus: for AviSynthPlus support'
- 'intel-media-sdk: for Intel Quick Sync Video'
'ladspa: for LADSPA filters'
- 'nvidia-utils: for Nvidia NVDEC/NVENC support')
+ 'nvidia-utils: for Nvidia NVDEC/NVENC support'
+ 'onevpl-intel-gpu: for Intel Quick Sync Video')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavutil.so' 'libpostproc.so' 'libswresample.so' 'libswscale.so'
'ffmpeg')
@@ -141,7 +141,6 @@ build() {
--enable-libiec61883 \
--enable-libjack \
--enable-libjxl \
- --enable-libmfx \
--enable-libmodplug \
--enable-libmp3lame \
--enable-libopencore_amrnb \
@@ -162,6 +161,7 @@ build() {
--enable-libvidstab \
--enable-libvmaf \
--enable-libvorbis \
+ --enable-libvpl \
--enable-libvpx \
--enable-libwebp \
--enable-libx264 \