summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD148
1 files changed, 76 insertions, 72 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8f3d69490975..02398bded7f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,89 +1,93 @@
-# Maintainer: Kamran Mackey <kamranm1200@gmail.com>
+# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Contributor: Kamran Mackey <kamranm1200@gmail.com>
# Contributor: richteer <richteer at lastprime.net>
# Contributor: DrZaius <lou at fakeoutdoorsman.com>
pkgname=ffmpeg-git
-pkgver=3.2.r80954.gd4c8e93
+pkgver=3.4.r86744.gfe9242204d
pkgrel=1
-pkgdesc="Complete solution to record, convert and stream audio and video (git version)"
+pkgdesc='Complete solution to record, convert and stream audio and video (git version)'
arch=('i686' 'x86_64')
-license=('GPL3' 'Non-free')
-url="http://ffmpeg.org/"
-depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'gmp' 'gnutls' 'gsm' 'lame'
- 'libass' 'libavc1394' 'libbluray' 'libiec61883' 'libmodplug' 'libpulse'
- 'libsoxr' 'libssh' 'libtheora' 'libva' 'libvdpau' 'libwebp'
- 'netcdf' 'opencore-amr' 'openjpeg' 'opus' 'schroedinger' 'sdl' 'speex'
- 'v4l-utils' 'xvidcore' 'zlib' 'libvidstab.so' 'libvorbis.so' 'libvorbisenc.so'
- 'libvpx.so' 'libx264.so' 'libx265.so' 'libfdk-aac')
-makedepends=('hardening-wrapper' 'ladspa' 'libvdpau' 'yasm' 'git')
+url='http://www.ffmpeg.org/'
+license=('GPL3')
+depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'
+ 'jack' 'lame' 'libavc1394' 'libiec61883' 'libmodplug' 'libpulse'
+ 'libraw1394' 'libsoxr' 'libssh' 'libtheora' 'libva' 'libvdpau'
+ 'libwebp' 'libx11' 'libxcb' 'opencore-amr' 'openjpeg2' 'opus'
+ 'schroedinger' 'sdl2' 'speex' 'v4l-utils' 'xz' 'zlib'
+ 'libass.so' 'libbluray.so' 'libfreetype.so' 'libvidstab.so'
+ 'libvorbisenc.so' 'libvorbis.so' 'libvpx.so'
+ 'libx264.so' 'libx265.so' 'libxvidcore.so')
+makedepends=('git' 'ladspa' 'nasm')
optdepends=('ladspa: LADSPA filters')
-provides=('ffmpeg' 'libavcodec.so' 'libavdevice.so' 'libavfilter.so'
+provides=('ffmpeg' 'qt-faststart' 'libavcodec.so' 'libavdevice.so' 'libavfilter.so'
'libavformat.so' 'libavresample.so' 'libavutil.so' 'libpostproc.so'
- 'libswresample.so' 'libswscale.so')
-conflicts=('ffmpeg' 'ffmpeg-full-git')
+ 'libswresample.so' 'libswscale.so')
+conflicts=('ffmpeg' 'ffmpeg-decklink' 'ffmpeg-libfdk_aac' 'ffmpeg-nvenc'
+ 'ffmpeg-qsv-git' 'ffmpeg-full' 'ffmpeg-full-git''ffmpeg-full-nvenc'
+ 'ffmpeg-semifull-git')
source=("$pkgname"::'git://source.ffmpeg.org/ffmpeg.git')
-md5sums=('SKIP')
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$pkgname"
- _ver="$(git describe --tags | sed 's|-[^.]*$||' | sed 's|^n||')"
- _rev="$(git rev-list --count HEAD)"
- _gitid="$(git rev-parse --short HEAD)"
- echo "${_ver}.r${_rev}.g${_gitid}"
+ cd "$pkgname"
+ local _version="$( git describe --tags --long | cut -d'-' -f1 | sed 's/^n//')"
+ local _revision="$( git describe --tags --match 'N' | cut -d'-' -f2)"
+ local _shorthash="$(git rev-parse --short HEAD)"
+ printf '%s.r%s.g%s' "$_version" "$_revision" "$_shorthash"
}
build() {
- cd "$srcdir/$pkgname"
-
- ./configure --prefix=/usr \
- --disable-debug \
- --disable-static \
- --enable-avisynth \
- --enable-avresample \
- --enable-fontconfig \
- --enable-gnutls \
- --enable-gpl \
- --enable-ladspa \
- --enable-libass \
- --enable-libbluray \
- --enable-libfreetype \
- --enable-libfribidi \
- --enable-libgsm \
- --enable-libmodplug \
- --enable-libmp3lame \
- --enable-libopencore_amrnb \
- --enable-libopencore_amrwb \
- --enable-libopenjpeg \
- --enable-libopus \
- --enable-libfdk-aac \
- --enable-libpulse \
- --enable-libschroedinger \
- --enable-libsoxr \
- --enable-libspeex \
- --enable-libssh \
- --enable-libtheora \
- --enable-libv4l2 \
- --enable-libvidstab \
- --enable-libvorbis \
- --enable-libvpx \
- --enable-libwebp \
- --enable-libx264 \
- --enable-libx265 \
- --enable-libxvid \
- --enable-nonfree \
- --enable-shared \
- --enable-version3 \
- --enable-x11grab \
-
- make EXTRA_CFLAGS="$CFLAGS"
- make tools/qt-faststart
- make doc/ff{mpeg,play,server}.1
+ cd "$pkgname"
+
+ msg2 'Running ffmpeg configure script. Please wait...'
+
+ ./configure \
+ --prefix='/usr' \
+ --disable-debug \
+ --disable-static \
+ --disable-stripping \
+ --enable-avisynth \
+ --enable-avresample \
+ --enable-fontconfig \
+ --enable-gmp \
+ --enable-gnutls \
+ --enable-gpl \
+ --enable-ladspa \
+ --enable-libass \
+ --enable-libbluray \
+ --enable-libfreetype \
+ --enable-libfribidi \
+ --enable-libgsm \
+ --enable-libiec61883 \
+ --enable-libmodplug \
+ --enable-libmp3lame \
+ --enable-libopencore_amrnb \
+ --enable-libopencore_amrwb \
+ --enable-libopenjpeg \
+ --enable-libopus \
+ --enable-libpulse \
+ --enable-libsoxr \
+ --enable-libspeex \
+ --enable-libssh \
+ --enable-libtheora \
+ --enable-libv4l2 \
+ --enable-libvidstab \
+ --enable-libvorbis \
+ --enable-libvpx \
+ --enable-libwebp \
+ --enable-libx264 \
+ --enable-libx265 \
+ --enable-libxcb \
+ --enable-libxvid \
+ --enable-shared \
+ --enable-version3
+ make
+ make tools/qt-faststart
}
package() {
- cd "$srcdir/$pkgname"
- make DESTDIR="$pkgdir" install install-man
- install -D -m755 tools/qt-faststart "$pkgdir/usr/bin/qt-faststart"
-}
-
-# vim: ts=8 sw=8 et:
+ cd "$pkgname"
+ make DESTDIR="$pkgdir" install
+ install -D -m755 tools/qt-faststart "${pkgdir}/usr/bin/qt-faststart"
+}