summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e4890ad16950..e537082c72ed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,23 +9,23 @@
_name=ffmpeg
pkgname=ffmpeg-libfdk_aac
pkgver=4.0
-pkgrel=1
+pkgrel=2
epoch=1
pkgdesc='Complete solution to record, convert and stream audio and video (Same as official package except with libfdk-aac support)'
arch=('x86_64')
url='http://ffmpeg.org/'
license=('GPL3' 'custom:libfdk-aac')
depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'
- 'jack' 'lame' 'libavc1394' 'libiec61883' 'libmodplug' 'libpulse'
- 'libraw1394' 'libsoxr' 'libssh' 'libtheora' 'libvdpau' 'libwebp'
- 'libx11' 'libxcb' 'libxml2' 'opencore-amr' 'openjpeg2' 'opus' 'sdl2'
- 'speex' 'v4l-utils' 'xz' 'zlib'
- 'libomxil-bellagio'
+ 'lame' 'libavc1394' 'libdrm' 'libiec61883' 'libmodplug'
+ 'libomxil-bellagio' 'libpulse' 'libraw1394' 'libsoxr' 'libssh'
+ 'libtheora' 'libvdpau' 'libwebp' 'libx11' 'libxcb' 'libxext' 'libxml2'
+ 'libxv' 'opencore-amr' 'openjpeg2' 'opus' 'sdl2' 'speex' 'v4l-utils'
+ 'xz' 'zlib'
'libass.so' 'libbluray.so' 'libfreetype.so' 'libva-drm.so' 'libva.so'
'libva-x11.so' 'libvidstab.so' 'libvorbisenc.so' 'libvorbis.so'
'libvpx.so' 'libx264.so' 'libx265.so' 'libxvidcore.so'
'libfdk-aac')
-makedepends=('ladspa' 'libvdpau' 'yasm')
+makedepends=('ffnvcodec-headers' 'ladspa' 'yasm')
optdepends=('ladspa: LADSPA filters')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
@@ -45,7 +45,6 @@ build() {
--disable-debug \
--disable-static \
--disable-stripping \
- --enable-avisynth \
--enable-avresample \
--enable-fontconfig \
--enable-gmp \
@@ -54,6 +53,7 @@ build() {
--enable-ladspa \
--enable-libass \
--enable-libbluray \
+ --enable-libdrm \
--enable-libfreetype \
--enable-libfribidi \
--enable-libgsm \
@@ -79,9 +79,10 @@ build() {
--enable-libxcb \
--enable-libxml2 \
--enable-libxvid \
+ --enable-nvenc \
+ --enable-omx \
--enable-shared \
--enable-version3 \
- --enable-omx \
--enable-libfdk_aac \
--enable-nonfree