summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 15 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 96da04ea4aba..bf463d87bc8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,10 +8,11 @@
# ALARM: Kevin Mihelich <kevin@archlinuxarm.org>
# - use -fPIC in host cflags for armv7 to fix print_options.c compile
+# - remove makedepends on ffnvcodec-headers, remove --enable-nvenc
# Upstream: https://raw.githubusercontent.com/archlinuxarm/PKGBUILDs/master/extra/ffmpeg/PKGBUILD
pkgname=ffmpeg-mmal
-pkgver=3.4.2
+pkgver=4.0
pkgrel=1
epoch=1
pkgdesc='ffmpeg built with MMAL hardware acceleration support for Raspberry Pi'
@@ -19,35 +20,25 @@ arch=('armv6h' 'armv7h' 'aarch64')
url='http://ffmpeg.org/'
license=('GPL3')
depends=('alsa-lib' 'bzip2' 'fontconfig' 'fribidi' 'glibc' 'gmp' 'gnutls' 'gsm'
- 'jack' 'lame' 'libavc1394' 'libiec61883' 'libmodplug' 'libpulse'
- 'libraw1394' 'libsoxr' 'libssh' 'libtheora' 'libvdpau' 'libwebp'
- 'libx11' 'libxcb' 'libxml2' 'opencore-amr' 'openjpeg2' 'opus' 'sdl2'
- 'speex' 'v4l-utils' 'xz' 'zlib'
- 'libomxil-bellagio'
+ 'lame' 'libavc1394' 'libdrm' 'libiec61883' 'libmodplug'
+ 'libomxil-bellagio' 'libpulse' 'libraw1394' 'libsoxr' 'libssh'
+ 'libtheora' 'libvdpau' 'libwebp' 'libx11' 'libxcb' 'libxext' 'libxml2'
+ 'libxv' 'opencore-amr' 'openjpeg2' 'opus' 'sdl2' 'speex' 'v4l-utils'
+ 'xz' 'zlib'
'libass.so' 'libbluray.so' 'libfreetype.so' 'libva-drm.so' 'libva.so'
'libva-x11.so' 'libvidstab.so' 'libvorbisenc.so' 'libvorbis.so'
'libvpx.so' 'libx264.so' 'libx265.so' 'libxvidcore.so'
'raspberrypi-firmware')
-makedepends=('ladspa' 'libvdpau' 'yasm')
+makedepends=('ladspa' 'yasm')
optdepends=('ladspa: LADSPA filters')
provides=('libavcodec.so' 'libavdevice.so' 'libavfilter.so' 'libavformat.so'
'libavresample.so' 'libavutil.so' 'libpostproc.so' 'libswresample.so'
'libswscale.so' 'ffmpeg')
conflicts=('ffmpeg')
-source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"{,.asc}
- 'fs56089.patch')
+source=("https://ffmpeg.org/releases/ffmpeg-${pkgver}.tar.xz"{,.asc})
validpgpkeys=('FCF986EA15E6E293A5644F10B4322F04D67658D8')
-sha256sums=('2b92e9578ef8b3e49eeab229e69305f5f4cbc1fdaa22e927fc7fca18acccd740'
- 'SKIP'
- '0bfcd12d1992903f21c146ae56d9ad89b52818cfb2303197ee905347c25a5427')
-
-prepare() {
- cd ffmpeg-${pkgver}
-
- # https://bugs.archlinux.org/task/56089
- # Backport of http://git.videolan.org/?p=ffmpeg.git;a=commitdiff;h=a606f27f4c610708fa96e35eed7b7537d3d8f712
- patch -Np1 -i ../fs56089.patch
-}
+sha256sums=('ed945daf40b124e77a685893cc025d086f638bc703183460aff49508edb3a43f'
+ 'SKIP')
build() {
cd ffmpeg-${pkgver}
@@ -59,7 +50,6 @@ build() {
--disable-debug \
--disable-static \
--disable-stripping \
- --enable-avisynth \
--enable-avresample \
--enable-fontconfig \
--enable-gmp \
@@ -68,6 +58,7 @@ build() {
--enable-ladspa \
--enable-libass \
--enable-libbluray \
+ --enable-libdrm \
--enable-libfreetype \
--enable-libfribidi \
--enable-libgsm \
@@ -94,15 +85,15 @@ build() {
--enable-libxml2 \
--enable-libxvid \
--enable-mmal \
- --enable-shared \
- --enable-version3 \
--enable-omx \
--enable-omx-rpi \
+ --enable-shared \
+ --enable-version3 \
$CONFIG
make
make tools/qt-faststart
- make doc/ff{mpeg,play,server}.1
+ make doc/ff{mpeg,play}.1
}
package() {