summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 12 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e89944493ae..3884d4169354 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@
# - Mirror: https://github.com/timvisee/ffsend/blob/master/pkg/aur/ffsend/PKGBUILD
pkgname=ffsend
-pkgver=0.2.50
+pkgver=0.2.51
pkgrel=1
pkgdesc="Easily and securely share files from the command line. A Firefox Send client."
url="https://gitlab.com/timvisee/ffsend"
license=('GPL3')
-source=("ffsend-v$pkgver.tar.gz::https://gitlab.com/timvisee/ffsend/-/archive/v0.2.50/ffsend-v0.2.50.tar.gz")
-sha256sums=('508ba88745090b510e8defe34c73d1cc662436e5c97439cf2b16b56b3670c840')
+source=("ffsend-v$pkgver.tar.gz::https://gitlab.com/timvisee/ffsend/-/archive/v0.2.51/ffsend-v0.2.51.tar.gz")
+sha256sums=('caa39c46f309a3da1724ef92c44fc04497eeb3b6c490a921a597d25d320ed7a4')
arch=('x86_64' 'i686')
provides=('ffsend')
depends=('ca-certificates')
@@ -30,8 +30,13 @@ package() {
# Install Binary
install -Dm755 "./target/release/ffsend" "$pkgdir/usr/bin/ffsend"
- # Install completions
- cd "./contrib/completions"
- install -Dm644 "ffsend.bash" "$pkgver/usr/share/bash-completion/completions/ffsend"
- install -Dm644 "ffsend.fish" "$pkgver/usr/share/fish/vendor_completions.d/ffsend.fish"
+ # Install shell completions and LICENSE file
+ install -Dm644 "contrib/completions/ffsend.bash" \
+ "$pkgdir/etc/bash_completion.d/ffsend"
+ install -Dm644 "contrib/completions/_ffsend" \
+ "$pkgdir/usr/share/zsh/site-functions/_ffsend"
+ install -Dm644 "contrib/completions/ffsend.fish" \
+ "$pkgdir/usr/share/fish/vendor_completions.d/ffsend.fish"
+ install -Dm644 "LICENSE" \
+ "$pkgdir/usr/share/licenses/ffsend/LICENSE"
}