summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3efb9b3718cc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=fhc
+pkgver=0.4.0
+pkgrel=1
+pkgdesc="Fast HTTP Checker"
+arch=('x86_64')
+url="https://github.com/Edu4rdSHL/fhc"
+license=('GPL3')
+makedepends=('cargo')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha512sums=('2a6e92c5b7dc7921d6a277b0fdbbddc1f6871ea436c2d76660f361e35a223df3a2b06c55f130d54fb9099f7222b381a0a49620fc4b9ea9d49fdc49cee8cbdb9b')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release --locked --all-features
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ cargo test --release --locked
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm 644 "$pkgname.1" -t "$pkgdir/usr/share/man/man1"
+}