summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 67b53782a57e..72fe223475d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: shimunn <shimun@shimun.net>
pkgname=fido2luks
-pkgver=0.2.16
-pkgrel=1
+pkgver=0.2.17
+pkgrel=2
makedepends=('rust' 'cargo' 'cryptsetup' 'clang')
depends=('cryptsetup')
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
pkgdesc="Decrypt your LUKS partition using a FIDO2 compatible authenticator"
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/shimunn/${pkgname}/archive/${pkgver}.tar.gz")
# curl -L https://github.com/shimunn/fido2luks/archive/0.2.16.tar.gz | sha256sum
-sha256sums=("353e77753bc496fd9ac6e12c8715e49d81cd66eec57e8f17c13723fa887cbcaf")
+sha256sums=("5cb921c6fcd55f23d608034d488e5dd43fc2be32d33c8436828079acc3f9a741")
url="https://github.com/shimunn/fido2luks"
license=('MPL-2.0')
@@ -16,10 +16,17 @@ build() {
cd "${pkgname}-${pkgver}"
cargo build --release --locked --all-features --target-dir=target
./target/release/fido2luks completions bash target
+ ./target/release/fido2luks completions fish target
}
package() {
cd "${pkgname}-${pkgver}"
install -Dm 755 target/release/${pkgname} -t "${pkgdir}/usr/bin"
+
+ install -Dm 755 pam_mount/fido2luksmounthelper.sh -t "${pkgdir}/usr/bin"
+ install -Dm 644 initcpio/hooks/fido2luks -t "${pkgdir}/usr/lib/initcpio/hooks"
+ install -Dm 644 initcpio/install/fido2luks -t "${pkgdir}/usr/lib/initcpio/install"
+
install -Dm 644 target/fido2luks.bash "${pkgdir}/usr/share/bash-completion/completions/fido2luks"
+ install -Dm 644 target/fido2luks.fish -t "${pkgdir}/usr/share/fish/vendor_completions.d"
}