summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 9 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dd5a8bdb92a9..1455bb7b0df4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=fife
pkgver=0.4.2
-pkgrel=1
+pkgrel=2
_githubname=fifengine
pkgdesc="Flexible Isometric Free Engine is a cross platform game creation framework"
arch=('i686' 'x86_64')
@@ -13,11 +13,14 @@ url="http://fifengine.net/"
license=('LGPL')
depends=('boost' 'fifechan' 'libvorbis' 'sdl2_ttf' 'openal' 'python' 'tinyxml' 'glew')
makedepends=('cmake' 'mesa' 'swig')
-source=("https://github.com/$_githubname/$_githubname/archive/$pkgver.tar.gz")
-sha512sums=('2b92e936d3f900532c5dee235a217c338941c44da479dceb3e48b3e8b93a402b31dc5501a6533391a01af53d6dbd51b6793c74e8ac81301ae6f1fa18271761a4')
+# source=("https://github.com/$_githubname/$_githubname/archive/$pkgver.tar.gz")
+# Needs to build at this commit to be able to build with swig 4, upstream doesn't want to tag:
+source=("$pkgver-d14f232.tar.gz::https://github.com/$_githubname/$_githubname/archive/d14f232f4cd9a00b05d6872957070e8c020f515d.tar.gz")
+sha512sums=('6fafca8e75b7f8a374b74c9e75cfa63208277f976ef9efcdb1da5c94a1ef46dacd320afe0b9dbd83a1ce8acb078a28d687328b3c4ba8227510f492e5a8df9373')
build() {
- cd "$_githubname-$pkgver"
+ # cd "$_githubname-$pkgver"
+ cd "$_githubname-d14f232f4cd9a00b05d6872957070e8c020f515d"
[[ -d "build" ]] && rm -r "build"
mkdir -p "build" && cd "build"
cmake \
@@ -30,7 +33,8 @@ build() {
}
package() {
- cd "$_githubname-$pkgver"
+ # cd "$_githubname-$pkgver"
+ cd "$_githubname-d14f232f4cd9a00b05d6872957070e8c020f515d"
cd "build"
make DESTDIR="$pkgdir" install
}