summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 16 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c3c8355fdec..269ac4f88a6d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,27 @@
-# Maintainer: Philip Goto <philip.goto@gmail.com>
+# Maintainer: Mattia Borda <mattiagiovanni.borda@icloud.com>
+# Contributor: Philip Goto <philip.goto@gmail.com>
# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=file-roller-git
-pkgver=3.31.1.r18.g74305535
+pkgver=43.0.r161.ge37ab4ac
pkgrel=1
pkgdesc="Create and modify archives"
url="https://wiki.gnome.org/Apps/FileRoller"
-arch=(x86_64)
-license=(GPL)
-depends=(gtk3 dconf libarchive file json-glib libnotify zip unzip)
-makedepends=(yelp-tools git libnautilus-extension meson appstream-glib)
+arch=(i686 x86_64 armv7h aarch64)
+license=(GPL2)
+depends=(libadwaita libarchive libportal-gtk4 libnautilus-extension)
+makedepends=(git meson yelp-tools)
optdepends=('p7zip: 7z, arj, exe and encrypted zip files support'
'unrar: better RAR archive support'
'unace: ACE archive support'
- 'lrzip: lrzip archive support')
-conflicts=(file-roller)
-provides=(file-roller)
+ 'lrzip: lrzip archive support'
+ 'squashfs-tools: squashfs image support')
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
groups=(gnome)
-source=("git+https://gitlab.gnome.org/GNOME/file-roller.git")
-sha256sums=('SKIP')
+source=(git+https://gitlab.gnome.org/GNOME/${pkgname%-git})
+b2sums=('SKIP')
pkgver() {
cd file-roller
@@ -27,14 +29,14 @@ pkgver() {
}
build() {
- arch-meson file-roller build
+ arch-meson ${pkgname%-git} build
ninja -C build
}
check() {
- meson test -C build
+ meson test -C build --print-errorlogs
}
package() {
DESTDIR="$pkgdir" meson install -C build
-} \ No newline at end of file
+}