summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 8 insertions, 44 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e813cabd0c4c..0e200a766d40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,14 @@
-# Maintainer : Kresimir Pripuzic <kpripuzic@gmail.com>
+# Contributor: Kresimir Pripuzic <kpripuzic@gmail.com>
# Contributor: Andrey Vetrov <vetrov@mail.ru>
# https://aur.archlinux.org/packages/file-roller-tmp/
pkgname=file-roller-tmp
-pkgver=3.36.1
-pkgrel=1
-pkgdesc="Create and modify archives. SSD-friendly version (stores temporary files in /tmp)."
-url="https://gitlab.gnome.org/GNOME/file-roller"
-arch=(x86_64)
+pkgver=3.36.2
+pkgrel=2
+pkgdesc="[Meta-PKG] Use 'file-roller' instead; delete this dummy metapackage"
+url="https://archlinux.org/packages/?q=file-roller"
+arch=(any)
license=(GPL2)
-provides=("file-roller=$pkgver")
conflicts=('file-roller')
-replaces=('file-roller')
-depends=('gtk3' 'dconf' 'libarchive' 'file' 'json-glib' 'libnotify' 'zip' 'unzip')
-makedepends=('yelp-tools' 'git' 'libnautilus-extension' 'meson' 'appstream-glib')
-optdepends=('p7zip: 7z, arj, exe and encrypted zip files support'
- 'unrar: better RAR archive support'
- 'unace: ACE archive support'
- 'lrzip: lrzip archive support')
-groups=(gnome)
-_commit=3e70dc594044b2792e8e2c50fa8ea79438b1ddfc # tags/3.36.1^0
-source=("git+https://gitlab.gnome.org/GNOME/file-roller.git#commit=$_commit"
- 'tmp-as-temp.patch')
-sha256sums=('SKIP' 'SKIP')
-
-pkgver() {
- cd ${pkgname:0:11}
- git describe --tags | sed 's/-/+/g'
-}
-
-prepare() {
- cd ${pkgname:0:11}
- #patch
- cd $srcdir/${pkgname:0:11}
- patch -Np0 -i ../tmp-as-temp.patch
-}
-
-build() {
- arch-meson ${pkgname:0:11} build
- ninja -C build
-}
-
-check() {
- meson test -C build
-}
-
-package() {
- DESTDIR="$pkgdir" meson install -C build
-}
+optdepends=('file-roller: migrate to this package instead of file-roller-tmp')
+install="${pkgname}.install"