summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0dc5d019e127..f803f47ea64e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,10 @@ license=('Apache')
makedepends=("dep" "git" "go" "yarn")
provides=('filebrowser')
conflicts=('filebrowser')
-source=("git+${url}.git")
-md5sums=('SKIP')
+source=("filebrowser.service"
+ "git+${url}.git")
+sha512sums=("2652a8617d5252ed7393b47f70e43eac91083e6b6353b5acab476379bf5ca66b6ef09302bce94bb8cf9f4368ccd4a8b7d34600e686c9a2c15e95a1ca12a23eb6"
+ "SKIP")
pkgver() {
git -C $_pkgname describe --tags | sed -e 's/^v//' -e 's/-/./g'
@@ -30,5 +32,7 @@ build() {
}
package() {
+ install -Dm644 "$pkgdir"/etc/$_pkgname
+ install -Dm644 "$srcdir"/$_pkgname.service "$pkgdir"/usr/lib/systemd/system/$_pkgname@.service
install -Dm755 "$GOPATH"/src/github.com/$_pkgname/$_pkgname/$_pkgname "$pkgdir"/usr/bin/$_pkgname
}