summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86d09b47f8b0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Kyle <kyle@gmx.ca>
+pkgname=files-f123light-git
+_gitname=files-F123Light
+pkgver=0.0 # automatically determined from git origin
+pkgrel=1
+pkgdesc="System and user configuration files, scripts and other files specific to F123Light, an ArchLinuxARM-based operating system for the Raspberry Pi 2 and 3"
+arch=(any)
+url="http://f123.org"
+license=('GPL3')
+depends=
+makedepends=('git')
+provides=
+conflicts=
+options=
+source=('git+https://github.com/F123/Files-F123Light.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd $_gitname
+ # Use the tag of the last commit
+ git describe --always | sed -e 's|v||' -e 's|-|.|g'
+}
+
+package() {
+ cd $_gitname
+ cp -a files/* $pkgdir
+}
+
+# vim:set ts=2 sw=2 et: