summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d1289ec5326d..f767ad5b7622 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
# Maintainer: Yamada Hayao <hayao@fascode.net>
_pkgname="filezilla"
-pkgname="$_pkgname-bin"
+pkgname="${_pkgname}-bin"
pkgver="3.54.1"
-pkgrel=1
+pkgrel="2"
pkgdesc='Free, open source FTP, FTPS and SFTP client (Pre-built binary)'
arch=('i686' 'x86_64')
url='https://filezilla-project.org'
license=('GPL')
depends=('pugixml' 'wxgtk3' 'xdg-utils' 'gmp' 'gnutls' 'nettle' 'sqlite')
-makedepends=('curl')
-provides=("${_pkgname}" "${_pkgname}-git")
-conflicts=("${_pkgname}" "${_pkgname}-git" "libfilezilla")
-machine_arch="${CARCH}"
-
-for _arch in ${arch[@]}; do
- eval "source_${_arch}=(FileZilla_${pkgver}_${_arch}-linux-gnu.tar.bz2::https://download.filezilla-project.org/client/FileZilla_${pkgver}_${_arch}-linux-gnu.tar.bz2)"
- eval "sha512sums_${_arch}=(SKIP)"
-done
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+# x86_64
+source_x86_64=("https://download.filezilla-project.org/client/FileZilla_${pkgver}_x86_64-linux-gnu.tar.bz2")
+sha512sums_x86_64=('034cb3a2d7258437e3a8b2193c342f818183bf25388b83cb1f5a7b4f81dbe27c67f1d32b5060de60628147ff214fbe0d2f392d4294c7ecbca9d3bcc701da0029')
+
+# i686
+source_i686=("https://download.filezilla-project.org/client/FileZilla_${pkgver}_i686-linux-gnu.tar.bz2")
+sha512sums_i686=('f0f5c54e9e3d630b75f353a1bde8da40eee1a24deb3ae3663cb1c2a9c5946e96bdd7fbdedc6fd259fa4a3665968960dec241dd7301b489306bc9f1dcf40262f1')
package() {