summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd543f429575..c3b5fec746d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,28 @@
_pkgname=filezilla
pkgname=$_pkgname-svn
-pkgver=7250
+pkgver=7603
pkgrel=1
-pkgdesc="Free, open source FTP, FTPS and SFTP client"
-arch=("i686" "x86_64")
-url="https://filezilla-project.org"
-license=("GPL")
-depends=("libfilezilla" "pugixml" "wxgtk" "xdg-utils")
-makedepends=("subversion")
+pkgdesc='Free, open source FTP, FTPS and SFTP client'
+arch=('i686' 'x86_64')
+url='https://filezilla-project.org'
+license=('GPL')
+depends=('libfilezilla' 'pugixml' 'wxgtk' 'xdg-utils')
+makedepends=('subversion')
provides=("$_pkgname")
conflicts=("$_pkgname")
-install=$pkgname.install
source=("$_pkgname::svn+https://svn.filezilla-project.org/svn/FileZilla3/trunk")
sha256sums=("SKIP")
+prepare() {
+ # Complement desktop entry file with key MimeTypes, https://trac.filezilla-project.org/ticket/10724
+ cd $_pkgname/data/
+ grep --quiet MimeType filezilla.desktop || echo 'MimeType=x-scheme-handler/ftp;' >> filezilla.desktop
+}
+
pkgver() {
cd $_pkgname
- svnversion
+ svnversion | sed 's:M$::'
}
build() {