summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 8 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ddb00ddd2011..3ef2e159fdb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,3 @@
-# $Id$
# Maintainer:
# SELinux Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
# SELinux Contributor: Timothée Ravier
@@ -8,34 +7,28 @@
# If you want to help keep it up to date, please open a Pull Request there.
pkgname=findutils-selinux
-pkgver=4.6.0
+pkgver=4.9.0
pkgrel=2
pkgdesc="GNU utilities to locate files with SELinux support"
-arch=('i686' 'x86_64')
+arch=('x86_64' 'aarch64')
license=('GPL3')
groups=('selinux')
depends=('glibc' 'sh' 'libselinux')
conflicts=("${pkgname/-selinux}" "selinux-${pkgname/-selinux}")
provides=("${pkgname/-selinux}=${pkgver}-${pkgrel}"
"selinux-${pkgname/-selinux}=${pkgver}-${pkgrel}")
-url="http://www.gnu.org/software/findutils"
-source=(https://ftp.gnu.org/pub/gnu/findutils/${pkgname/-selinux}-${pkgver}.tar.gz
- gnulib-glibc2.28-compatibility.patch)
-sha1sums=('f18e8aaee3f3d4173a1f598001003be8706d28b0'
- '089b2f56a7c4b24e03184c158f1352ade2b5d050')
-#validpgpkeys=('A15B725964A95EE5') # James Youngman <james@youngman.org>
-
-prepare() {
- cd "${srcdir}/${pkgname/-selinux}-${pkgver}"
- patch -Np1 -i ../gnulib-glibc2.28-compatibility.patch
-}
+url='https://www.gnu.org/software/findutils/'
+source=("https://ftp.gnu.org/pub/gnu/findutils/${pkgname/-selinux}-${pkgver}.tar.xz"{,.sig})
+sha256sums=('a2bfb8c09d436770edc59f50fa483e785b161a3b7b9d547573cb08065fd462fe'
+ 'SKIP')
+validpgpkeys=('A5189DB69C1164D33002936646502EF796917195') # Bernhard Voelker <mail@bernhard-voelker.de>
build() {
cd "${srcdir}/${pkgname/-selinux}-${pkgver}"
# Don't build or install locate because we use mlocate,
# which is a secure version of locate.
- sed -i '/^SUBDIRS/s/locate//' Makefile.in
+ sed -e '/^SUBDIRS/s/locate//' -e 's/frcode locate updatedb//' -i Makefile.in
./configure --prefix=/usr
# don't build locate, but the docs want a file in there.