summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e2846c799c8..d07dd53b2cba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,29 @@
# Contributor: Antonio Vázquez Blanco <antoniovazquezblanco@gmail.com>
+# Contributor: Haruue Icymoon <haruue@caoyue.com.cn>
pkgname=firebird-nspire
-pkgver=0.30
+pkgver=1.2
pkgrel=1
pkgdesc='Community emulator of TI-Nspire calculators.'
arch=('i686' 'x86_64')
url='https://github.com/nspire-emus/firebird'
conflicts=('nspire_emu')
-license=()
+license=('GPL3')
depends=()
-makedepends=('qt5-declarative')
-source=("$pkgname-$pkgver.tar.gz"::'https://github.com/nspire-emus/firebird/archive/v'$pkgver'.tar.gz')
-md5sums=('b441ef38da179a7e48c407d47d5cf294')
+makedepends=('qt5-declarative>=5.6' 'git')
+source=("${pkgname}"::'git+https://github.com/nspire-emus/firebird')
+md5sums=('SKIP')
+
+prepare() {
+ cd "${srcdir}/${pkgname}"
+ git checkout -b "v${pkgver}" "v${pkgver}"
+ git submodule init
+ git submodule update
+}
build() {
# Compile...
- cd "${srcdir}/firebird-${pkgver}"
+ cd "${srcdir}/${pkgname}"
mkdir -p build
cd build
qmake ..
@@ -24,6 +32,7 @@ build() {
package() {
# Install...
- cd "${srcdir}/firebird-${pkgver}/build"
+ cd "${srcdir}/${pkgname}/build"
INSTALL_ROOT="${pkgdir}" make install
}
+