summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c34f8971e5dc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
+
+pkgname=firefox-css-exfil-protection
+pkgver=1.0.12
+pkgrel=1
+pkgdesc='Guard against CSS data exfiltration attacks'
+url=https://www.mike-gualtieri.com/css-exfil-vulnerability-tester
+arch=('any')
+license=('MIT')
+groups=('firefox-addons')
+source=("https://addons.cdn.mozilla.net/user-media/addons/931864/css_exfil_protection-$pkgver-an+fx.xpi")
+noextract=("${source##*/}")
+sha256sums=('a48f1af6db0c2761acf7bfca4f0a580bc2b233564307abba6c9700950da9c40d')
+
+package() {
+ install -Dm644 "${source##*/}" "$pkgdir"/usr/lib/firefox/browser/extensions/{7fc8ef53-24ec-4205-87a4-1e745953bb0d}.xpi
+}
+
+# vim:set ts=2 sw=2 et: