summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 721a7f015ec6..ca60eea472ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,24 @@
# Contributor: Vinycius Maia <suportevg@uol.com.br>
pkgname=firefox-extension-greasemonkey
-_file=370452
-pkgver=3.6
+_file=402242
+pkgver=3.7
pkgrel=1
pkgdesc="Customize the way a web page displays or behaves, by using small bits of JavaScript."
arch=('any')
url="http://www.greasespot.net/"
license=('MPL')
-depends=('firefox>=35.0')
+depends=('firefox>=38.0')
source=(https://addons.mozilla.org/firefox/downloads/file/$_file/greasemonkey-$pkgver.xpi)
-sha1sums=('35b76e5cc77087ac1fc6b0400fc4d0ae57eb57d5')
+sha1sums=('d1a43b10e9ffadaf95d0558bb57dd467758e6de2')
package() {
- cd "$srcdir"
- local emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf)
- local dstdir="$pkgdir/usr/lib/firefox/browser/extensions/$emid"
- find . -type f -exec install -Dm644 '{}' "$dstdir/{}" \;
+ cd $srcdir
+ local _emid=$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' install.rdf) || return 1
+ test ! -z "${_emid}"
+ local _file=(*.xpi)
+ test "${#_file[@]}" -eq 1
+ install -Dpm644 "${_file}" "${pkgdir}/usr/lib/firefox/browser/extensions/${_emid}.xpi"
}
# vim:set ts=2 sw=2 et: