summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e182260e6857..15af9da0b02c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
+# Maintainer: Que Quotion <quequotion@bugmenot.com>
# Contributor: Ramana Kumar <firstname@member.fsf.org>
pkgname=firefox-sync
-pkgver=20150305
+pkgver=20180112
pkgrel=1
pkgdesc="Speed up Firefox using tmpfs"
arch=('i686' 'x86_64')
@@ -8,8 +9,9 @@ url="http://wiki.archlinux.org/index.php/Speed-up_Firefox_using_tmpfs"
license=('GPL')
depends=('rsync' 'firefox')
makedepends=('bash')
-source=(${pkgname})
-md5sums=('4e7949eaed8f284233d2ecdecc28534c')
+source=(${pkgname} 'firefox-sync.desktop')
+md5sums=('4e7949eaed8f284233d2ecdecc28534c'
+ '710f182537f640ce8ca77474e7943113')
package() {
sed -i "3 c\
LINK=$(ls -d1 ~/.mozilla/firefox/*.default | head -n 1 | xargs basename)
@@ -18,8 +20,9 @@ LINK=$(ls -d1 ~/.mozilla/firefox/*.default | head -n 1 | xargs basename)
cd ${pkgdir}/usr/bin
bash -c '{
echo "#!/bin/bash"
-echo "firefox-sync && firefox && firefox-sync"
+echo "firefox-sync && firefox \"\${@}\" && firefox-sync"
} > syncfox'
find ${pkgdir}/usr/bin -type f -exec chmod 755 {} \;
find ${pkgdir}/usr/bin -type d -exec chmod 755 {} \;
+ install -Dm 644 {"${srcdir}","${pkgdir}"/etc/xdg/autostart}/firefox-sync.desktop
}