summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD54
1 files changed, 18 insertions, 36 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fad160f07caa..a21efcee5188 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,35 @@
-# Maintainer: Arif <>
-# Contributors: Gui||aume <michaudg@gmail.com>
-
+# Maintainer: Gu1ll0me <michaudg@gmail.com>
+# Contributor: aimileus <me at aimileus dot nl>
pkgname=firefox-ubuntu-bin
-_pkgname=firefox
-pkgver=65.0
+pkgver=105.0
pkgrel=1
-_ubuntuver="$pkgver+build2-0ubuntu1_amd64"
+_ubuntuver="$pkgver+build2-0ubuntu0.18.04.1_amd64"
pkgdesc="Standalone web browser from mozilla.org with Ubuntu patches (binary)"
arch=("x86_64")
url="https://www.mozilla.org/firefox/"
-license=('GPL' 'LGPL' 'MPL')
-depends=(
- 'dbus-glib'
- 'ffmpeg'
- 'gtk3'
- 'hunspell'
- 'icu'
- 'libpulse'
- 'libvpx'
- 'libxt'
- 'mime-types'
- 'mozilla-common'
- 'nss'
- 'sqlite'
- 'startup-notification'
- 'ttf-font'
-)
-optdepends=(
- 'libnotify: Notification integration'
- 'networkmanager: Location detection via available WiFi networks'
- 'pulseaudio: Audio support'
- 'speech-dispatcher: Text-to-Speech'
-)
-provides=('firefox' 'firefox-ubuntu')
+license=(MPL GPL LGPL)
+depends=(gtk3 libxt startup-notification mime-types dbus-glib ffmpeg nss
+ ttf-font libpulse)
+optdepends=('appmenu-gtk-module: for KDE global menu'
+ 'libdbusmenu-gtk3: for KDE global menu'
+ 'networkmanager: Location detection via available WiFi networks'
+ 'libnotify: Notification integration'
+ 'pulseaudio: Audio support'
+ 'speech-dispatcher: Text-to-Speech'
+ 'hunspell-en_US: Spell checking, American English')
+provides=('firefox')
conflicts=('firefox' 'firefox-ubuntu')
-source=("http://archive.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_$_ubuntuver.deb")
-sha256sums=('skip')
+source=("http://security.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_$_ubuntuver.deb")
+md5sums=('a249044709f2c15d9b74608524ead686')
+
prepare() {
# Don't extract copyright files, which are included in the licenses package
tar -xvf data.tar.xz --exclude=usr/share/doc
- # UBUNTU_MENUPROXY=0 is a requirement for global menus
- # https://github.com/rilian-la-te/vala-panel-appmenu/issues/125
- sed -i 's|Exec=firefox|Exec=env UBUNTU_MENUPROXY=0 firefox|' usr/share/applications/firefox.desktop
}
package() {
cp -r etc "$pkgdir/"
cp -r usr "$pkgdir/"
}
-