summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24fe71411214
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: aimileus < $(echo YWltaWxpdXNAcHJvdG9ubWFpbC5jb20K | base64 -d) >
+pkgname=firefox-ubuntu-bin
+_pkgname=firefox
+pkgver=58.0
+_ubuntuver="$pkgver+build6-0ubuntu0.17.10.1_amd64"
+pkgrel=1
+pkgdesc="Standalone web browser from mozilla.org with Ubuntu patches (binary)"
+arch=("x86_64")
+url="https://www.mozilla.org/firefox/"
+license=('GPL' 'LGPL' 'MPL')
+depends=(
+ 'dbus-glib'
+ 'ffmpeg'
+ 'gtk2'
+ 'gtk3'
+ 'hunspell'
+ 'icu'
+ 'libpulse'
+ 'libvpx'
+ 'libxt'
+ 'mime-types'
+ 'mozilla-common'
+ 'nss'
+ 'sqlite'
+ 'startup-notification'
+ 'ttf-font'
+)
+optdepends=(
+ 'libnotify: Notification integration'
+ 'networkmanager: Location detection via available WiFi networks'
+ 'pulseaudio: Audio support'
+ 'speech-dispatcher: Text-to-Speech'
+)
+provides=('firefox' 'firefox-ubuntu')
+conflicts=('firefox' 'firefox-ubuntu')
+source=("http://archive.ubuntu.com/ubuntu/pool/main/f/firefox/firefox_$_ubuntuver.deb")
+md5sums=('f0f4787491e5731c50c20cd7a74f4504')
+
+prepare() {
+ tar xvf data.tar.xz
+ # UBUNTU_MENUPROXY=0 is a requirement for global menus
+ # https://github.com/rilian-la-te/vala-panel-appmenu/issues/125
+ sed -i 's|Exec=firefox|Exec=env UBUNTU_MENUPROXY=0 firefox|' usr/share/applications/firefox.desktop
+}
+
+package() {
+ install -Dm755 etc usr -t "$pkgdir/"
+}