summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD75
1 files changed, 54 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 230cd6d730c3..2d1fdc883eff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,44 +2,77 @@
# Contributor: Eric Belanger <eric@archlinux.org>
# Contributor: Jan Fader <jan.fader@web.de>
# Contributor: Stephen Drodge <stephen.drodge@gmail.com>
+# Contributor: Akatsuki Rui <aur@akii.work>
# Maintainer: SanskritFritz (gmail)
pkgname=fish-git
_gitname="fish-shell"
-pkgver=3.0.2.r1024.g0784b7657
+pkgver=3.7.0.r1420.g776895274
pkgrel=1
epoch=2
pkgdesc="User friendly shell intended mostly for interactive use."
arch=('i686' 'x86_64' 'arm')
url="http://fishshell.com"
-license=("GPL2")
-depends=('ncurses')
-optdepends=('python: fish_update_completions and other tools'
- 'xsel: clipboard integration'
- 'jq: bower and yarn completions')
-makedepends=('cmake' 'python-sphinx' 'git')
-provides=('fish' 'fish-shell')
-conflicts=('fish' 'fish-shell')
+license=('GPL2')
+depends=(
+ 'glibc'
+ 'ncurses'
+ 'pcre2'
+)
+optdepends=(
+ 'python: man page completion parser / web config tool'
+ 'pkgfile: command-not-found hook'
+)
+makedepends=(
+ 'cargo'
+ 'cmake'
+ 'git'
+ 'python-sphinx'
+)
+checkdepends=(
+ 'expect'
+ 'procps-ng'
+)
+options=(!lto)
+provides=(
+ 'fish'
+ 'fish-shell'
+)
+conflicts=(
+ 'fish'
+ 'fish-shell'
+)
+source=(
+ "git+https://github.com/fish-shell/fish-shell.git"
+)
install='fish.install'
-source=("git://github.com/fish-shell/fish-shell.git")
-md5sums=('SKIP')
+backup=(etc/fish/config.fish)
+b2sums=('SKIP')
pkgver() {
- cd "$_gitname"
- git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ cd "$_gitname"
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd "$srcdir/$_gitname"
- mkdir -p build
- cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_INSTALL_SYSCONFDIR=/etc -DCMAKE_BUILD_TYPE=Release ..
- make
+ cd "$_gitname"
+ export CXXFLAGS+=" ${CPPFLAGS}"
+ cmake \
+ -B build \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc \
+ -DBUILD_DOCS=True \
+ -Wno-dev
+ make -C build
+}
+check() {
+ cd "$_gitname"
+ make -C build test
}
package() {
- cd "$srcdir/$_gitname/build"
- make DESTDIR="$pkgdir" install
-
+ cd "$_gitname"
+ make -C build DESTDIR="$pkgdir" install
}