summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e359f85266fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Sefa Eyeoglu <contact@scrumplex.net>
+# Contributor: Daniel Maslowski <info@orangecms.org>
+
+pkgname=fisher-git
+pkgver=3.1.0.r0.gddf7334
+pkgrel=1
+pkgdesc="A blazing fast, modern plugin manager for fish"
+arch=("any")
+url="https://github.com/jorgebucaran/fisher"
+license=("MIT")
+depends=("fish>=2.3.0" "curl" "git")
+makedepends=("git")
+conflicts=("fisherman" "fisherman-git" "fisher")
+install=fisher-git.install
+source=(
+ "git+https://github.com/jorgebucaran/fisher.git"
+)
+sha512sums=(
+ "SKIP"
+)
+
+pkgver() {
+ cd "fisher"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ sharepath="${pkgdir}/usr/share"
+ fishpath="${sharepath}/fish"
+ # install Fisherman into the global fish directory
+ cd "fisher"
+ install -Dm 644 fisher.fish "${fishpath}/functions/fisher.fish"
+ # README and LICENSE
+ install -Dm 644 LICENSE.md "${sharepath}/licenses/${pkgname}/LICENSE.md"
+ install -Dm 644 README.md "${sharepath}/doc/${pkgname}/README"
+}