summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 21 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91d6ba18c778..7691b72d1961 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,33 @@
# Submitter: L.G. Sarmiento <lgsarmientop-ala-unal.edu.co>
pkgname=fityk-git
-pkgver=20140531
+_pkgname=fityk
+pkgver=r1713.d3bd1341
pkgrel=1
pkgdesc="A program for nonlinear fitting of analytical functions to data."
url="http://fityk.nieto.pl/"
-arch=('i686' 'x86_64')
+arch=('x86_64')
license=('GPL2')
-depends=('lua' 'wxgtk' 'xylib' 'ruby' 'python')
-makedepends=('boost' 'desktop-file-utils' 'git' 'python2-sphinx' 'swig')
+depends=('xylib' 'boost' 'lua' 'swig')
+makedepends=('git')
optdepends=('gnuplot: can be used with the CLI')
provides=("fityk")
options=('!libtool')
install="fityk.install"
-md5sums=()
+source=($_pkgname::git+https://github.com/wojdyr/fityk.git
+ "fityk.install")
+md5sums=('SKIP'
+ '0f2c2b78511036ea623a9568509bc987')
-_gitroot="http://github.com/wojdyr/fityk.git"
+pkgver() {
+
+ cd ${srcdir}/$_pkgname
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+
+}
build() {
- [ -d ${srcdir}/${pkgname} ] || mkdir ${srcdir}/${pkgname}
- #thanks to masutu and in general the team from the fityk AUR package
- #This nowadays is almost identical to that one.
- cd ${srcdir}/${pkgname}
- git clone --depth 1 $_gitroot .
+
+ cd ${srcdir}/$_pkgname
#it doesn't build with sphinx for python3
sed -i 's#sphinx-build#sphinx-build2#' doc/Makefile
@@ -30,9 +36,12 @@ build() {
--prefix=/usr \
--with-wx-config=/usr/bin/wx-config
make || return 1
+
}
package() {
- cd ${srcdir}/${pkgname}
+
+ cd ${srcdir}/${_pkgname}
make DESTDIR=${pkgdir} install
+
}