summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a8bc1e82395..4440f28a6b9b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=flac2all
pkgver=5.0
-pkgrel=1
+pkgrel=2
pkgdesc="Multi-threaded audio converter of FLAC to either Ogg Vorbis or MP3 retaining all tags and metadata."
arch=('any')
url="https://github.com/ZivaVatra/flac2all"
@@ -18,12 +18,16 @@ optdepends=(
'python-pyzmq: for clustering'
'vorbis-tools: for ogg support'
)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/ZivaVatra/$pkgname/archive/v$pkgver.tar.gz")
-sha256sums=('d18a01653eed4d497cc1fe0393fecfaf6b6eab5dac9bd5599d1e83231b76c22d')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ZivaVatra/$pkgname/archive/v$pkgver.tar.gz"
+01-unfuck_python3.patch::https://github.com/ZivaVatra/flac2all/commit/dfe6d201d57866905dabf6bbcae4d396e4e4d130.patch
+)
+sha256sums=('d18a01653eed4d497cc1fe0393fecfaf6b6eab5dac9bd5599d1e83231b76c22d'
+ '2ad929c76351bcb63782ce06c45db62abfad6191be498914abaf17321e71479c')
prepare() {
cd "$pkgname-$pkgver"
[[ -f version ]] || echo "v$pkgver" > version
+ patch -Np1 -i ../01-unfuck_python3.patch
}
build() {